Microsoft Excel

Herbers Excel/VBA-Archiv

Namen suchen / Formel gesucht oder VBA | Herbers Excel-Forum


Betrifft: Namen suchen / Formel gesucht oder VBA von: Ilka Maria
Geschrieben am: 29.11.2009 13:31:00

Hallo,

in Spalte A stehen Nachnamen, in Spalte B Vornamen.
In C1 soll ein gesuchter Nachname, in D1 ein gesuchter Vorname eingetragen werden.
Mit Hilfe einer Formel oder eines VBA-Programms soll nun die ZeilenNr in E1 ermittelt werden.
Wer kann helfen?
Gruß
Ilka Maria

  

Betrifft: AW: Namen suchen / Formel gesucht oder VBA von: Hajo_Zi
Geschrieben am: 29.11.2009 13:45:33

Hallo Ilka,


Tabelle1

 ABCDEF
1Nachname1Vorname1Nachname4Vorname4Nachname4Vorname4Nachname1Vorname1
2Nachname2Vorname2nName steht4 Zeile  Nachname2Vorname2
3Nachname3Vorname3      Nachname3Vorname3
4Nachname4Vorname4      Nachname4Vorname4
5Nachname5Vorname5      Nachname5Vorname5
6Nachname6Vorname6      Nachname6Vorname6
7Nachname7Vorname7      Nachname7Vorname7
8Nachname8Vorname8      Nachname8Vorname8
9Nachname9Vorname9      Nachname9Vorname9
10Nachname10Vorname10      Nachname10Vorname10
11Nachname11Vorname11      Nachname11Vorname11
12Nachname12Vorname12      Nachname12Vorname12
13Nachname13Vorname13      Nachname13Vorname13

verwendete Formeln
Zelle Formel
E1 =C1&D1
F1 =A1&B1
D2 =WENN(ISTFEHLER(VERGLEICH(E1;F1:F13;0));"";VERGLEICH(E1;F1:F13;0))
F2 =A2&B2
F3 =A3&B3
F4 =A4&B4
F5 =A5&B5
F6 =A6&B6
F7 =A7&B7
F8 =A8&B8
F9 =A9&B9
F10 =A10&B10
F11 =A11&B11
F12 =A12&B12
F13 =A13&B13

Zahlenformate
Zelle Format Wert
D2 0 " Zeile"4
Zellen mit Format Standard werden nicht dargestellt

Tabellendarstellung in Foren Version 4.31



GrußformelHomepage


  

Betrifft: AW: Danke schön von: Ilka Maria
Geschrieben am: 29.11.2009 16:02:18

Hallo Hajo,

ich danke Dir für die Formeln. Damit ist die Aufgabe gelöst.

Gruß
Ilka Maria


  

Betrifft: {=VERGLEICH(C1&D1;A1:A99&B1:B99;0)} von: WF
Geschrieben am: 29.11.2009 14:43:15

ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter (statt Enter allein); - das erzeugt sie.

Salut WF


  

Betrifft: AW: Danke schön von: Ilka Maria
Geschrieben am: 29.11.2009 16:00:18

Hallo WF,

ich danke Dir für die Arrayformel. Damit ist die Aufgabe gelöst.

Gruß
Ilka Maria


Beiträge aus den Excel-Beispielen zum Thema "Namen suchen / Formel gesucht oder VBA"