Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Wenn-Befehl mit und / oder

Wenn-Befehl mit und / oder
Elmar
Hallo Experten,
kann mir jemand helfen?
Ich habe die Formel, die auch soweit klappt....
=WENN(UND(A11="Mo";P11="Feiertag");0;WENN(UND(A11="Di";P11="Feiertag");0;WENN(UND(A11="Mi"; P11="Feiertag");0;WENN(UND(A11="Do";P11="Feiertag");0;WENN(UND(A11="Fr";P11="Feiertag");0; WENN(A11="Sa";0;WENN(A11="So";0;$J$6)))))))
Nun bräuchte ich noch eine Bedingung drin, dass wenn ich P11 nicht Feiertag sondern Krankheit steht, dass dann auch "0" ausgegeben wird.
Kann mir jemand helfen?
Danke und Grüße
Elmar

9
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Wenn-Befehl mit und / oder
06.10.2009 13:45:19
Matthias5
Hallo Elmar,
=WENN(UND(ODER(A11={"Mo"."Di"."Mi"."Do"."Fr"."Sa"."So"});ODER(P11={"Feiertag"."Krankheit"}));0;$J$6)
Gruß,
Matthias
AW: Wenn-Befehl mit und / oder
06.10.2009 13:56:59
Elmar
Hallo Matthias,
mit Deiner Formel übernimmt er, wenn in Spalte "A" Sa oder So steht, nun auch den Wert aus J6, da soll er dann eben auch "0" bringen.
Kannst Du nochmals schauen, danke
Elmar
AW: Wenn-Befehl mit und / oder
06.10.2009 13:58:46
JogyB
Hi Matthias,
danke, die Schreibweise ist mir in meinem Beispiel nicht eingefallen ;)
Du hast aber einen kleinen Fehler drin, da bei Sa und So keine Überprüfung auf ein zweites Kriterium stattfinden darf:
=WENN(ODER(A11={"Sa"."So"});0;WENN(UND(ODER(A11={"Mo"."Di"."Mi"."Do"."Fr"}); ODER(P11={"Feiertag"."Krankheit"}));0;$J$6))
Wobei vermutlich auch das ausreichen würde:
=WENN(ODER(ODER(A11={"Sa"."So"});ODER(P11={"Feiertag"."Krankheit"}));0;$J$6)
Gruss, Jogy
Anzeige
Richtig, danke! Nicht genau genug hingesehen! oT
06.10.2009 14:02:41
Matthias5
Gruß,
Matthias
AW: Wenn-Befehl mit und / oder
06.10.2009 13:48:36
JogyB
Hi.
Jetzt ohne das Ganze genauer zu analysieren:
Ersetze das
P11="Feiertag"
durch
ODER(P11="Feiertag";P11="Krankheit")
Oder Du schreibst es etwas kürzer in der Form
=WENN(ODER(A11="Sa";A11="So");0;WENN(UND(ODER(A11="Mo";A11="Di";A11="Mi";A11="Do";A11="Fr"); ODER(P11="Feiertag";P11="Krankheit"));0;$J$6))
Gruss, Jogy
geht kürzer
06.10.2009 13:56:42
WF
Hi,
=WENN(SUMME((A11={"Mo";"Di";"Mi";"Do";"Fr";"Sa";"So"})*1)*((P11="Feiertag")+(P11="Krankheit"))=1;0; J6)
Salut WF
AW: geht kürzer
06.10.2009 14:05:28
Elmar
Super, DANKE ...... klappt jetzt bestens
Grüße vom Bodensee
Elmar
AW: geht kürzer
06.10.2009 14:06:50
JogyB
Hi WF,
auch derselbe Fehler, Sa und So sind extra zu behandeln:
=WENN(SUMME((A11={"Mo";"Di";"Mi";"Do";"Fr"})*1)*((P11="Feiertag")+(P11="Krankheit"))+((A11<> "Sa")+(A11<>"So"))=1;0; $J$6)
Gruss, Jogy
Anzeige
AW: Wenn-Befehl mit und / oder
06.10.2009 18:12:09
BoskoBiati
Hallo zusammen,
das Ganze könnte man doch eigentlich auf folgende Formel reduzieren:
=WENN(ODER(P11="Feiertag";A11="Sa";A11="So";P11="K");0;J6)
Gruß
Bosko

322 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige