Microsoft Excel

Herbers Excel/VBA-Archiv

WENN ODER Funktion? | Herbers Excel-Forum


Betrifft: WENN ODER Funktion? von: Anna
Geschrieben am: 23.02.2010 14:49:23

Hallo Forumsteilnehmer!

Ich habe folgendes Problem:
Ich habe ganz viele Spalten, in der jedes Mal entschieden werden muss, ob der Inhalt einer Zelle größer oder kleiner als zwei andere Zellen ist. Also stehen z.B. in der Spalte A1:A20 Zahlen, und ich will, das jede dieser Zahlen ersetzt wird (mit 0), wenn diese entweder größer als eine Zahl in A21 oder kleiner als eine Zahl in A22 ist, wenn beides nicht zutrifft, soll die Zahl stehen bleiben, also nichts passieren.
Dasselbe will ich dann auch für Spalte B1:B20 haben, mit größer als B21 oder kleiner als B22 und so weiter. Ich habe es so probiert (Formel eingetragen in Zelle A23), aber es funktioniert nicht.

=WENN(ODER(A1:A20<A21;A1:A20>A22);0;"")

Das kann doch so schwer nicht sein? Wer kann mir helfen?
Danke! Anna

  

Betrifft: AW: WENN ODER Funktion? von: Rudi Maintaire
Geschrieben am: 23.02.2010 16:17:32

Hallo,
entweder Formeln oder Werte in Zellen. Beides geht nicht.

Gruß
Rudi


  

Betrifft: AW: WENN ODER Funktion? von: Anna
Geschrieben am: 23.02.2010 16:34:17

Hallo Rudi,
danke für deine Antwort. Leider verstehe ich sie nicht. Ich habe ja nur Werte in den Zellen und nur eine, diese, Formel in der anderen. Oder worauf beziehst du dich?
Gibt es also keine Lösung für das Problem?
Grüße, Anna


  

Betrifft: Deine Fml, wenn sie denn richtig angewandt... von: Luc:-?
Geschrieben am: 23.02.2010 16:18:50

…wird, Anna,
ersetzt die Zahlen in A1:A20 auf jeden Fall. Denn, was die Fml aussagt ist…
Wenn die jeweils aktuelle Zahl aus A1:A20 < Zahl in A21 oder > Zahl in A22 ist, gib als Ergebnis 0, sonst einen Leerstring aus!
Wenn du die Fml also als sog Matrixformel einsetzt, wird sie in jeder Zelle ihres Standortbereichs entweder 0 oder Leer, aber niemals den Wert aus A1:A20 ausgeben.
Ich gehe bisher davon aus, dass alle Zahlen stets nur mit A21 und A22 vgl wdn und deine Fml in einer anderen Spalte des Blattes steht*. Dann müsste sie wie folgt lauten…
{=WENN(ODER(A1:A20<A21;A1:A20>A22);0;A1:A20)}
* Es wäre auch möglich, die Fml direkt in Spalte A, quasi „um die Originaldaten herum“ unterzubringen. Das wäre am Einfachsten mit einer entsprechd VBA-Subroutine zu bewerkstelligen.
Gruß Luc :-?


  

Betrifft: AW: WENN ODER Funktion? von: Renee
Geschrieben am: 23.02.2010 16:22:45

Hi Anna,

Nun von A1:A20 sind es 20 Zahlen, also muss das Resultat auch wieder aus 20 Zahlen bestehen.

=WENN(ODER(A1 > A$21;A1 < A$22);0;A1) 
in A23 und bis A53 Formel runterkopieren. Anschliessend nach rechts für weitere Spalten!

GreetZ Renée


  

Betrifft: AW: WENN ODER Funktion? von: Anna
Geschrieben am: 23.02.2010 16:41:16

Hallo Renee,
tausend Dank! Das ist ne gute Lösung. Ich hatte den - vermutlich banalen - Trick mit dem $ Zeichen noch nicht drauf, so dass sich bei dieser Lösung vorher ALLE Bezüge und nicht nur der nebenstehende Zellenbezug verändert hatte. Jetzt weiss ichs. Danke! Anna


  

Betrifft: Meine Erklärung scheinst du ja nicht zu... von: Luc:-?
Geschrieben am: 23.02.2010 16:55:42

…verstehen, Anna,
oder warum ignorierst du sie? Dann kannst du allerdings auch nicht xlGut sein!
Von solchen „Selbstüberschätzern“ habe ich langsam die Nase voll und werde deshalb derartige, von fehletikettierter Ahnungslosigkeit geprägte Beiträge nicht mehr beantworten! :-<
Luc :-?


  

Betrifft: AW: Meine Erklärung scheinst du ja nicht zu... von: Anna
Geschrieben am: 23.02.2010 17:54:23

Hey Luc, danke auch für deinen Beitrag. Hatte nicht mehr lange drüber nachgedacht, weil ich meine Aufgabe schnell zu Ende bringen wollte und Renees Lösung bereits gut gepasst hat.
Grüße, Anna


  

Betrifft: Hmmh...! oW & owT von: Luc:-?
Geschrieben am: 23.02.2010 18:04:00

:-?


Beiträge aus den Excel-Beispielen zum Thema "WENN ODER Funktion?"