Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zählenwenn und "MittelwertWenn"

Zählenwenn und "MittelwertWenn"
Dietmar
Hallo allerseits,
suche bisher erfolglos zwei Formeln zur berechnung von diversen Spalten (hier im Beispiel nur eine)
Einmal für die Zählung der Häufigkeit (also Anzahl2) und
einmal für die Berechnung eines Mittelwertes ... jedesmal wenn zwei Bedingungen erfüllt sind.
Rahmenbedingungen:
Spalte A2:A100 = Jahr
Spalte B2:B100 = Kalenderwochen
Spalte C2:C100 = Umsätze
Nun möchte ich folgendes:
(A)
In D2 soll die Anzahl der KW-Einträge gezählt werden, wenn:
a) in Spalte A das Jahr 2011 steht und
b) in Spalte B die Zahl 1 bis 13 steht (dies entspräche also dem 1. Quartal 2011)
Da jeder Umsatzeintrag eine neue Lesezeile hat, kommt z.B. die KW 1 oder 3 o.ä. mehrfach vor.
(B)
In E2 soll der Mittelwert der Umsätze aus Spalte C angezeigt werden, wenn:
siehe obige Bedingungen
Die weiteren Quartale könnte ich mir selbst zusammenstellen, wenn ich das Lösungsprinzip kennen würde.
Mit dem Spezialfilter möchte ich es nicht machen, weil keine Zeilen ausgeblendet werden sollen.
Jetzt bin ich gespannt, ich habs versucht ... :-(
Vielen Dank und viele Grüße
Dietmar aus Aachen

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
Pivot-Tabelle owT
03.11.2010 16:38:30
Rudi
möchte es mit Formel und ohne Pivot machen
03.11.2010 16:45:13
Dietmar
Hallo Rudi,
vielen Dank!
Pivot wäre eine Möglichkeit. Ich möchte die Berechnung aber in eine bestehende Datenseite einbauen und ohne Pivot arbeiten.
Gruß
Dietmar
AW: möchte es mit Formel und ohne Pivot machen
03.11.2010 18:21:20
Tino
Hallo,
meinst Du so?
 ABCDEF
1JahrKWUmsatz AnzahlMittelwert
2201111 23
3201022   
42011143   
52010104   
6201135   
7201056   
82011167   

Formeln der Tabelle
ZelleFormel
E2{=SUMME((A2:A8=2011)*(B2:B8<14)*1)}
F2{=SUMME(WENN((A2:A8=2011)*(B2:B8<14); C2:C8))/E2}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Gruß Tino
Anzeige
1000 Dank! Ja, das ist es
03.11.2010 18:28:00
Dietmar
Hallo Tino,
super!
Herzlichen Dank für Deine Mühe. Damit komme ich prima klar.
Schönen Abend noch!
Gruß
Dietmar

345 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige