Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zählenwenn(s) aber Unterschiedliche

Zählenwenn(s) aber Unterschiedliche
UweD
Hallo
ich komm einfach nicht drauf.
in der Tabelle möchte ich die roten Zahlen erhalten.
- Anzahl der Unterschiedlichen Artikel je Lieferant
- Anzahl, an wieviel Tager Lieferant angeliefert hat.
Tabelle1

 ABCDEFGHIJ
1AnlieferungLieferantArtikelMenge  LieferantAnzahl LieferungenAnzahl ArtikelAnzahl Liefertage
212.05.2012MüllerAAA100  Müller432
312.05.2012MüllerBBB50  Weber313
414.05.2012WeberCCC10  Meier532
514.05.2012MüllerDDD10  Obi111
614.05.2012MeierEEE20      
714.05.2012MeierFFF10    ??
814.05.2012MeierGGG50      
914.05.2012MeierEEE10      
1014.05.2012MüllerBBB5      
1115.05.2012WeberCCC20      
1216.05.2012ObiXYZ5      
1316.05.2012WeberCCC10      
1416.05.2012MeierGGG50      

Formeln der Tabelle
ZelleFormel
H2=ZÄHLENWENN(B:B;G2)
H3=ZÄHLENWENN(B:B;G3)
H4=ZÄHLENWENN(B:B;G4)
H5=ZÄHLENWENN(B:B;G5)



Wer kann helfen?
Danke und Grüsse aus Siegen

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Zählenwenn(s) aber Unterschiedliche
16.05.2012 12:40:47
hary
Hallo Uwe
Hab hier kein 2007.
Aber Liefertage:
=SUMMENPRODUKT(($B$1:$B$99=E2)*($A$1:$A$99<>"")/ZÄHLENWENN($A$1:$A$99;$A$1:$A$99&""))
siehe: http://www.excelformeln.de/formeln.html?welcher=42
gruss hary
AW: Zählenwenn(s) aber Unterschiedliche
16.05.2012 12:51:35
Sheldon
Hallo Uwe, hallo hary,
auf die 42 bin ich auch erst gekommen, aber besser noch passt 334. Die habe ich mal auf beide Fragestellungen angewendet:
Tabelle1
 ABCDEFGHIJ
1AnlieferungLieferantArtikelMenge    LieferantAnzahl LieferungenAnzahl ArtikelAnzahl Liefertage
212.05.2012MüllerAAA100    Müller432
312.05.2012MüllerBBB50    Weber313
414.05.2012WeberCCC10    Meier532
514.05.2012MüllerDDD10    Obi111
614.05.2012MeierEEE20           
714.05.2012MeierFFF10           
814.05.2012MeierGGG50           
914.05.2012MeierEEE10           
1014.05.2012MüllerBBB5           
1115.05.2012WeberCCC20           
1216.05.2012ObiXYZ5           
1316.05.2012WeberCCC10           
1416.05.2012MeierGGG50           

verwendete Formeln
Zelle Formel Bereich
H2 =ZÄHLENWENN($B$2:$B$14;G2) 
I2 {=SUMME((VERGLEICH($B$1:$B$14&$C$1:$C$14;$B$1:$B$14&$C$1:$C$14;0)=ZEILE($1:$14)*($B$1:$B$14=G2)*($C$1:$C$14<>""))*1)} $I$2
J2 {=SUMME((VERGLEICH($B$1:$B$14&$A$1:$A$14;$B$1:$B$14&$A$1:$A$14;0)=ZEILE($1:$14)*($B$1:$B$14=G2)*($A$1:$A$14<>""))*1)} $J$2
H3 =ZÄHLENWENN($B$2:$B$14;G3) 
I3 {=SUMME((VERGLEICH($B$1:$B$14&$C$1:$C$14;$B$1:$B$14&$C$1:$C$14;0)=ZEILE($1:$14)*($B$1:$B$14=G3)*($C$1:$C$14<>""))*1)} $I$3
J3 {=SUMME((VERGLEICH($B$1:$B$14&$A$1:$A$14;$B$1:$B$14&$A$1:$A$14;0)=ZEILE($1:$14)*($B$1:$B$14=G3)*($A$1:$A$14<>""))*1)} $J$3
H4 =ZÄHLENWENN($B$2:$B$14;G4) 
I4 {=SUMME((VERGLEICH($B$1:$B$14&$C$1:$C$14;$B$1:$B$14&$C$1:$C$14;0)=ZEILE($1:$14)*($B$1:$B$14=G4)*($C$1:$C$14<>""))*1)} $I$4
J4 {=SUMME((VERGLEICH($B$1:$B$14&$A$1:$A$14;$B$1:$B$14&$A$1:$A$14;0)=ZEILE($1:$14)*($B$1:$B$14=G4)*($A$1:$A$14<>""))*1)} $J$4
H5 =ZÄHLENWENN($B$2:$B$14;G5) 
I5 {=SUMME((VERGLEICH($B$1:$B$14&$C$1:$C$14;$B$1:$B$14&$C$1:$C$14;0)=ZEILE($1:$14)*($B$1:$B$14=G5)*($C$1:$C$14<>""))*1)} $I$5
J5 {=SUMME((VERGLEICH($B$1:$B$14&$A$1:$A$14;$B$1:$B$14&$A$1:$A$14;0)=ZEILE($1:$14)*($B$1:$B$14=G5)*($A$1:$A$14<>""))*1)} $J$5
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen


Gruß
Sheldon
Anzeige
AW: Zählenwenn(s) aber Unterschiedliche
16.05.2012 13:09:47
UweD
Hallo Sheldon, hallo hary
das klappt bestens.
mit der Formel 42 bin ich nicht zurecht gekommen.
Besten Dank.
Gruß UweD

312 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige