Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema RefEdit
BildScreenshot zu RefEdit RefEdit-Seite mit Beispielarbeitsmappe aufrufen

Zählenwenn über vielspaltigen Bereich | Herbers Excel-Forum


Betrifft: Zählenwenn über vielspaltigen Bereich von: Christian
Geschrieben am: 08.01.2010 18:00:32

Hallo,

ich suche eine Formel (kein VBA!), die einen Bereich in Spalte F nach einem Kriterium (steht in E259) durchsucht und dann die Anzahl der zugehörigen Werte der Spalten G:CC anzeigt. Mit Zählenwenn würde das so aussehen:
=ZÄHLENWENN(G3:CC258;F3:F258=E259)
Falls es von Belang ist: Im Bereich G3:CC258 stehen Formeln und Leerzellen.
Ich weiß, das Zählenwenn nicht über mehrere Spalten funktioniert. Leider waren meine Versuche mit Summenfunktionen (auch als Array) leider erfolglos. In der Recherche konnte ich auch nichts passendes finden. Wäre schön, wenn mir jemand helfen könnte.
Vielen Dank bereits im voraus.

Gruß Christian

  

Betrifft: AW: Zählenwenn über vielspaltigen Bereich von: Josef Ehrensberger
Geschrieben am: 08.01.2010 18:11:30

Hallo Christian,

deine Frage ist etwas verwirrend.

In E259 steht der Begriff der in F3:F258 gesucht werden soll - Klar.

In G3:C258 soll nun was gezählt werden? Die einträge (<>"") in der entsprechenten Zeile (Fundstelle)?


Gruß Sepp



  

Betrifft: AW: Zählenwenn über vielspaltigen Bereich von: Christian
Geschrieben am: 08.01.2010 18:31:35

Hallo, Sepp,

das Suchkriterium aus E259 ergibt mehrere Treffer, z.B. F3: F8. Dann möchte ich die Anzahl der Werte größer Null wissen, die sich insgesamt im Bereich G3:CC8 befinden.
Ich hoffe, dass es jetzt verständlicher ist.

Gruß Christian


  

Betrifft: AW: Zählenwenn über vielspaltigen Bereich von: Josef Ehrensberger
Geschrieben am: 08.01.2010 19:24:43

Hallo Christian,

=SUMMENPRODUKT((G3:CC258>0)*(F3:F258=E259))

Gruß Sepp



  

Betrifft: AW: Zählenwenn über vielspaltigen Bereich von: Christian
Geschrieben am: 08.01.2010 20:40:49

Hallo, Sepp,

vielen Dank für die Formel. Sie liefert allerdings ein erstaunliches Ergebnis:
Das Suchkriterium in E259 liefert 5 Treffer im Bereich F3:F258. In den 5 Trefferzeilen (=G3:CC7) befinden sich 255 Formeln, wo von 241 Formeln einen Wert ungleich Null anzeigen(235 leer und 6 einen Wert größer Null). Die Formel liefert als Ergebnis tatsächlich 241!
Hab den Bereich G3:CC258 in der Formel zu Testzwecken mal um einige Spalten verkleinert, aber immer wieder wird die Anzahl der Formeln ungleich Null (die sich dann entsprechend verringert) angezeigt.
Als Array liefert sie das gleiche Ergebnis.
Hast du (oder jemand anders) eine Erklärung dafür?

Gruß Christian


  

Betrifft: AW: Zählenwenn über vielspaltigen Bereich von: Christian
Geschrieben am: 08.01.2010 21:00:37

O.K.,

ich weiß zwar nicht, warum die Formeln, die ein leeres Ergebnis anzeigen, mitgezählt werden, aber ich hab jetzt herausgefunden, wie man's umgehen kann:
=SUMMENPRODUKT((G3:CC258>0)*(G3:CC258<>"")*(F3:F258=E259))
Vielen Dank noch mal, Sepp.

Gruß Christian


  

Betrifft: AW: Zählenwenn über vielspaltigen Bereich von: Josef Ehrensberger
Geschrieben am: 08.01.2010 21:18:19

Hallo Christian,

ganz einfach, weil "" nunmal größer 0 ist.

Tabelle1

 A
1 
20
3WAHR

Formeln der Tabelle
ZelleFormel
A1=""
A2=0
A3=A1>A2


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



Beiträge aus den Excel-Beispielen zum Thema "Zählenwenn über vielspaltigen Bereich"