Microsoft Excel

Herbers Excel/VBA-Archiv

Zählenwenn mit Teilstring | Herbers Excel-Forum


Betrifft: Zählenwenn mit Teilstring von: Stefan Ludwig
Geschrieben am: 14.12.2009 10:56:53

Hallo,

Tabelle 1
A B
333012345 888
340023456 777

Tabelle 2
A B C
10000 20000 888
20000 50000 777
Fragestellung : ich will in Tabelle 1 Spalte B mit dem Inhalt von Spalte C aus Tabelle3 füllen. Bedingung :
ich suche zu Spalte A, Stelle 5-9 (also 12345 oder 23456) das passende Intervall in Tabelle 2.
z. B. zu A1 wäre B1 = 888, weil 12345 im Inervall (10000 - 20000) liegt.

Kann man das mit ZÄHLENWENN lösen ?

viele Grüße, Stefan

  

Betrifft: =sverweis() von: ransi
Geschrieben am: 14.12.2009 11:04:43

HAllo Stefan

Nutze doch einfach den sverweis() !?!? :

Tabelle1

 ABC
1333012345888 
2340023456777 
3   

Formeln der Tabelle
ZelleFormel
B1=SVERWEIS(TEIL(A1;5;5)*1;Tabelle2!$A$1:$C$9;3)
B2=SVERWEIS(TEIL(A2;5;5)*1;Tabelle2!$A$1:$C$9;3)


Tabelle2

 ABCD
11000020000888 
22000150000777 
3    


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


ransi


  

Betrifft: AW: =sverweis() von: Stefan Ludwig
Geschrieben am: 14.12.2009 11:41:23

Hallo Ransi,

danke schon mal für die Hilfe. Beim ausprobieren bringt das für die beiden Beispiele das erwartete Ergebnis. Aber bei 350088888 kommt auch 777 heraus - obwohl kein passendes Intervall in Tabelle2 vorliegt. Kann es sein, daß nur Spalte A gecheckt wird (mit <= ), aber nicht Spalte B (mit >=).

Gruß, Stefan


  

Betrifft: AW: =sverweis() von: ransi
Geschrieben am: 14.12.2009 12:13:18

HAllo

Kann es sein, daß nur Spalte A gecheckt wird (mit <= ), aber nicht Spalte B (mit >=).

Jep, genau so ist es.

KAnnst du aber ganz leicht ergänzen:
Tabelle1

 ABC
1333012345888 
2340023456777 
3350088888  
4   

Formeln der Tabelle
ZelleFormel
B1=SVERWEIS(TEIL(A1;5;5)*1;Tabelle2!$A$2:$C$9;3)
B2=SVERWEIS(TEIL(A2;5;5)*1;Tabelle2!$A$2:$C$9;3)
B3=SVERWEIS(TEIL(A3;5;5)*1;Tabelle2!$A$2:$C$9;3)


Tabelle2

 ABCD
10   
21000020000888 
32000150000777 
450001   
5    

Formeln der Tabelle
ZelleFormel
C1=""
C4=""


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

ransi


  

Betrifft: AW: =sverweis() von: Stefan Ludwig
Geschrieben am: 14.12.2009 15:10:06

Hallo Ransi,

nach Durchsicht meiner kompletten Tabelle2 glaube ich, daß SVERWEIS mein Problem nicht löst, da die Intervalle nicht komplett abdeckend sind. Welche Alternative gibt es ggf. für das Problem ?

Tabelle2 :
A B C
10000 20000 888
20001 50000 777
60000 80000 999

Gruß, Stefan


Beiträge aus den Excel-Beispielen zum Thema "Zählenwenn mit Teilstring"