Abfrage größerer oder kleinerer Wert in Spalte

Bild

Betrifft: Abfrage größerer oder kleinerer Wert in Spalte
von: Stark
Geschrieben am: 13.07.2015 20:15:46

Folgende Frage:
Kann man folgende Formel vereinfachen ohne Makro
=WENN(C14>C13;1;WENN(C15>C13;2;WENN(C16>C13;3;WENN(C17>C13;4;WENN(C18>C13;5; WENN(C19>C13;6; WENN(C20>C13;7;WENN(C21>C13;8;WENN(C22>C13;9;WENN(C23> C13; 10; WENN(C24>C13;11;WENN(C25>C13; 12; WENN(C26>C13;13;WENN(C27>C13;14; WENN(C28>C13;15; WENN(C29>C13;16;WENN(C30>C13;17; WENN(C31>C13; 18; WENN(C32> C13;19;WENN(C33>C13;20;21)) ))))))))))))))))))
Eeigentlich würde ich gerne mehr als die nächsten 21 Zellen abfragen!
Kann man eventuell eine Funktion programmieren?
Ich brauche bitte eure Hilfe

Bild

Betrifft: AW: Abfrage größerer oder kleinerer Wert in Spalte
von: Sepp
Geschrieben am: 13.07.2015 20:22:00
Hallo Stark,

=WENNFEHLER(AGGREGAT(14;6;ZEILE($A$1:$A$21)/(C14:C33>C13:C32);1);21)
obwohl ich nicht sicher bin, ob du das so meinst.
Gruß Sepp


Bild

Betrifft: Falsch gelesen!
von: Sepp
Geschrieben am: 13.07.2015 20:46:53
Hallo Stark,
eine von den Beiden?
Tabelle2

 BCDEFGH
12       
13 2   11 
14 1   2 
15 3     
16 1     
17 1     
18 1     
19 1     
20 1     
21 1     
22 1     
23 1     
24 6     
25 1     
26 1     
27 1     
28 1     
29 1     
30 1     
31 1     
32 1     
33 1     

Formeln der Tabelle
ZelleFormel
G13=WENNFEHLER(AGGREGAT(14;6;ZEILE($A$1:$A$21)/(C14:C33>C13); 1); 21)
G14=WENNFEHLER(AGGREGAT(15;6;ZEILE($A$1:$A$21)/(C14:C33>C13); 1); 21)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Sepp


Bild

Betrifft: hast es ja noch gemerkt
von: WF
Geschrieben am: 13.07.2015 20:53:58
die aggregatlose Formel wäre.
{=WENN(C13=MAX(C13:C33);21;MIN(WENN(C14:C33>C13;ZEILE(1:20))))}
WF

Bild

Betrifft: {=MIN(WENN(C14:C33>C13;ZEILE(1:20);21))}
von: WF
Geschrieben am: 13.07.2015 21:11:36
schrauben kann man immer

Bild

Betrifft: AW: {=MIN(WENN(C14:C33>C13;ZEILE(1:20);21))}
von: Stark
Geschrieben am: 14.07.2015 08:51:40
Hallo WF,
die Formel ganz unten ("schrauben kann man immer")funktioniert in der Zelle prima.
Ich habe nur das Problem, dass ich die Matrixformel nicht nach unten kopieren kann.
Dann verändern sich die Werte in Zeile (1:20) auf Zeile (2:21) Zeile (3:22) usw.
Kann man die Formel so generieren, dass die Zahl 1 bis 20 beim runterkopieren konstant bleibt??

Bild

Betrifft: feste Bezüge - also Dollars
von: WF
Geschrieben am: 14.07.2015 09:58:10
Hi
wenn Du nur 1:20 fixieren willst, dann:
{=MIN(WENN(C14:C33>C13;ZEILE($1:$20);21))}
WF

Bild

Betrifft: AW: Frage zu ZEILE()...
von: Daniel
Geschrieben am: 14.07.2015 10:07:45
... warum referenzierst du hier auf die ganze Zeile (Zeile(1:20)) ?
das hat doch zur folge, dass die Formel bei jeder Änderung in diesem Zellbereich neu berechnet wird, obwohl das gar nicht notwendig ist, weil dieser Zellbereich für das Formelergebnis irrelevant ist.
Damit machst du die Formel "teil-volatil".
Ein Zeile(A1:A20) würde doch das gleiche Ergebnis liefern und den Zeilbereich, der eine Neuberechung auslöst, deutlich verkleinern.
Gruß Daniel

Bild

Betrifft: es gibt keinen Grund
von: WF
Geschrieben am: 14.07.2015 10:29:27
Hi,
- hatte ich schlicht vergessen
ZEILE(X$1:X$20)
ist natürlich besser (ich nehm lieber X statt A, falls vorne mal Spalten gelöscht werden.
WF

Bild

Betrifft: AW: es gibt keinen Grund
von: Daniel
Geschrieben am: 14.07.2015 10:36:11
ok, Spalten löschen abzusichern wäre tatsächlich ein Argument.
Gruß Daniel

Bild

Betrifft: AW: feste Bezüge - also Dollars
von: Stark
Geschrieben am: 14.07.2015 10:09:20
Hallo WF,
Vielen, vielen Dank - das war es...
ich wusste und kannte nicht, dass man in diesem Fall die Dollars vor den Zahlen schreibt.
Beste Grüße
Stark

Bild

Betrifft: AW: hast es ja noch gemerkt
von: Stark
Geschrieben am: 14.07.2015 08:56:35
Hallo Sepp,
vielen Dank - bei mir funktioniert das leider nicht. Ich bekomme falsche Zahlenwerte....
...und weiß nicht warum.
In den Zellen A1 bis A21 stehen bei mir natürlich irgendwelche Zahlenwerte
Ich hoffe, du weiß Rat...

Bild

Betrifft: was funktioniert denn nicht? ...
von: der neopa C
Geschrieben am: 14.07.2015 09:30:08
Hallo,
... welche Formel hast Du denn nun genutzt? Die Werte in den Zellen A1:A24 haben absolut keinen Einfluss auf das Ergebnis mit den Formeln die hier vorgeschlagen wurden.
Wie sieht denn Dein Tabellenauszug aus. Stell doch mal eine kleine Datei ein. Dann wird es klarer, wo das Problem liegt.
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Abfrage größerer oder kleinerer Wert in Spalte"