Fehlermeldung bei mehr als zwei Werten in Spalte

Bild

Betrifft: Fehlermeldung bei mehr als zwei Werten in Spalte
von: Ingo
Geschrieben am: 02.09.2015 16:34:05

Hallo zusammen,
für einen Spätdienstplaner soll es nicht möglich sein, dass sich pro Tag mehr als zwei Leute in die Spätschicht eintragen, somit soll in der Spalte des Tages bei der dritten Eingabe (Drop-Down-Menü) eine Warnmeldung kommen, dass kein dritter Wert möglich ist. Geht das irgendwie?

Bild

Betrifft: AW: mit benutzerdefinierter Datengültigkeit ...
von: ... neopa C
Geschrieben am: 02.09.2015 16:43:08
Hallo Ingo,
... in den entsprechenden Zellen und einer Formel wie


 =ANZAHL2(E$2:E$9)<3 
wenn die Eintragungen in Spalte E z.B. in den Zellen E2:E9 vorgenommen werden sollen.
Dies an Deine Spalten und Zellbereiche entsprechend anpassen.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Fehlermeldung bei mehr als zwei Werten in Spalte
von: Ingo
Geschrieben am: 02.09.2015 18:11:00
Hallo Werner,
vielen Dank für die schnelle Antwort, leider hat es nicht geklappt bzw. ich wende Deinen Tipp falsch an.
Angenommen, ich habe in den Zellen A3:A10 die Namen von Mitarbeitern 1-8, in Spalte B kann dann jeder Mitarbeiter seine Schicht auswählen (Schichtarten sind als DropDown hinterlegt). Wir benötigen jeden Tag maximal zwei Leute in der Spätschicht. Nun soll in B3:B10 der dritte User, welcher bei sich eine Spätschicht einträgt, eine Warnung bekommen, dass bereits zwei vergeben sind. Die zwei vergebenen Schichten sind variabel und können oben oder unten sein. Weißt Du, was ich meine?

Bild

Betrifft: AW: so wie Du jetzt schreibst ...
von: ... neopa C
Geschrieben am: 03.09.2015 15:20:35
Hallo Ingo,
... markiere B3:B10 aktiviere die Datengültigkeit, Zulassen: benutzerdefiniert und Formel


 =ANZAHL2(B$2:B$10)<3 
Gruß Werner
.. , - ...

Bild

Betrifft: gleichzeitig mit Liste?
von: Rudi Maintaire
Geschrieben am: 03.09.2015 15:45:53
Hallo Werner,
...(Schichtarten sind als DropDown hinterlegt). ....
wie geht das?
Gruß
Rudi

Bild

Betrifft: AW: na, ja, man sich nur zu helfen wissen ;-) ...
von: ... neopa C
Geschrieben am: 03.09.2015 17:05:13
Hallo Rudi,
... das mit der bereits vergebenen Dropdownliste hab ich überlesen :-( weil letzte Stunden vor Urlaub :-)
Wenn ich etwas mehr Zeit hätte, würde ich über eine bessere Lösung als nachfolgende nochmal nachdenken.
Nachfolgender "arbeite" ich ohne Fehlermeldung, biete dafür aber die jeweilige Schichtart nicht mehr an (wohl wissend, dass man das "aushebeln" kann, wenn man keine besonderen Vorkehrungen trifft).
@Ingo,
... in einer Hilfsspalte (ausblendbar, bei mir Spalte H) definiere die Liste für Deine Dropdownliste (ich hab sie Art genannt) über Formel wie aufgezeigt.

 ABCDEFGH
1       Schicht
2       früh
3Name1       
4Name2spät     Nacht
5Name3       
6Name4früh      
7Name5spät      
8Name6       
9Name7Nacht      
10Name8       
11        

Formeln der Tabelle
ZelleFormel
H2=WENN(ZÄHLENWENN($B$3:$B$10;"früh")>1;"";"früh")
H3=WENN(ZÄHLENWENN($B$3:$B$8;"spät")>1;"";"spät")
H4=WENN(ZÄHLENWENN($B$3:$B$8;"Nacht")>1;"";"Nacht")

Datengültigkeit der Tabelle
ZelleZulassenDatenEingabe 1Eingabe 2
B3Liste =Art 
B4Liste =Art 
Namen in Formeln
ZelleNameBezieht sich auf
B3Art=Tabelle7!$H$2:$H$4
B4Art=Tabelle7!$H$2:$H$4
Namen verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Fehlermeldung bei mehr als zwei Werten in Spalte"