Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn Wert in Spalte dann in dieser Zeile .....

Betrifft: Wenn Wert in Spalte dann in dieser Zeile ..... von: He Du da
Geschrieben am: 18.11.2014 08:18:09

guten morgen excelgemeinde,
sitze seit gestern an einem problem was sicher leicht zu lösen ist, ich excel & VBA neuling bin jedoch schon mit meinem latein am ende.



Folgender Sachverhalt:
In den Spalten A;B;C werden von Hand Werte eingetragen, in Zelle F3 wird ebenfalls ein Wert eingetragen.
Nun soll der Wert aus F3 in der Spalte C gesucht -- und wo gefunden in dieser zeile -- die spalten (B - A) gerechnet werden.
Und zwar in allen möglichen fällen wo der wert in spalte C auftaucht; diese werte sollen dann addiert und in Zelle F4 ausgegeben werden.

mein ansatz: =Wenn(ZÄHLENWENN(C2:C5;F3);...........
mehr bekomm ich nicht zusammen. hab mich gestern mit der Index-funktion belesen und hoffte dort eine möglichkeit zu finden, leider ohne erfolg.

Ist das was ich von Excel verlange überhaupt mit einer Funktion möglich?
Wäre ich mit VBA vielleicht besser beraten?
Wenn jmd. einen ansatz zur Lösung hätte wäre das echt toll.
danke schonmal

  

Betrifft: AW: Wenn Wert in Spalte dann in dieser Zeile ..... von: Oberschlumpf
Geschrieben am: 18.11.2014 08:32:11

Hi ???

Trag in F4 diese Formel ein:
=ZÄHLENWENN(C2:C5;F3)

Hilfts?

Ciao
Thorsten


  

Betrifft: mit SUMMENPRODUKT() ... von: neopa C (paneo)
Geschrieben am: 18.11.2014 08:33:14

Hallo,

... =SUMMENPRODUKT(A2:B5*(C2:C5=F3)) erhälst Du die gewünschte Summe.

Gruß Werner
.. , - ...


  

Betrifft: AW: Wenn Wert in Spalte dann in dieser Zeile ..... von: Matthias L
Geschrieben am: 18.11.2014 08:36:53

Hallo

Ich hoffe ich hab Dich richtig verstanden ...

 ABCEF
1StartEndeStatus  
2241  
3480Status1
48161Wert10
516320  

Formeln der Tabelle
ZelleFormel
F4{=SUMME(WENN(C2:C5=$F$3;B2:B5-A2:A5))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Matthias


  

Betrifft: erscheint logischer als meine Interpretation .... von: neopa C (paneo)
Geschrieben am: 18.11.2014 08:43:11

Hallo Matthias,

... in dem Fall würde ich dann allerdings das einfachere: =SUMMENPRODUKT((B2:B5-A2:A5)*(C2:C5=F3))
vorschlagen.

Gruß Werner
.. , - ...


  

Betrifft: Einverstanden ;-) ... owT von: Matthias L
Geschrieben am: 18.11.2014 08:52:39




  

Betrifft: AW: erscheint logischer als meine Interpretation .... von: He Du da
Geschrieben am: 18.11.2014 08:57:17

vielen dank; funktioniert so wie es soll. ihr seit klasse


 

Beiträge aus den Excel-Beispielen zum Thema "Wenn Wert in Spalte dann in dieser Zeile ....."