Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
156to160
156to160
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Wenn Text = keine Berechnung, Wenn Zahl über Svers

Wenn Text = keine Berechnung, Wenn Zahl über Svers
13.09.2002 09:33:40
markus
hallo !
ich habe in einer tabelle das problem das ich über einen sverweis daten suche, aber nur wenn in der zelle z.b. eine artikelnummer steht. wenn ein text drin steht soll er nicht über den sverweis suchen.
was könnte ich da probieren?

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Re: Wenn Text = keine Berechnung, Wenn Zahl über Svers
13.09.2002 09:40:10
ANdreas
Hallo Markus,

wenn die Artikelnummer eine Zahl ist (also nicht alphanumerisch), dann kannst Du dass mit der Funktion ISTZAHL() feststellen.

Das ganze könnte dann etwa so aussehen:
=WENN(ISTZAHL(A1);SVERWEIS(...);"Kein SVerweis")

Hoffe das hilft weiter,
Andreas

Re: Wenn Text = keine Berechnung, Wenn Zahl über Svers
13.09.2002 10:23:49
Boris
Hallo Markus,

da ich davon ausgehe, dass deine SVERWEIS-Suche mit einem Text zu einem Fehlerwert (wie #NV) führt, kannst du auch schreiben:

=wenn(istfehler(sverweis(a1;c1:d10;2;falsch));"";sverweis(...)

Somit liest du den Fehlerwert vorher aus und unterdrückst diesen mit "".

Gruß Boris

Re: Wenn Text = keine Berechnung, Wenn Zahl über Svers
13.09.2002 11:16:49
Michael Wendeler
Hallo,

versuch es so:

=wenn(ISTTEXT(A1);"keine Artikelnummer";SVERWEIS(....))

Gruß
M. Wendeler
http://www.wendelers.de

Anzeige
Besten Dank Andreas! Funktioniert
13.09.2002 11:38:26
markus
gruss markus

382 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige