Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Finde bel. Zahl in Text

Finde bel. Zahl in Text
Florian
Hallo zusammen!
Ich bin auf der Suche nach einer verallgemeinerten Find-Funktion. Hintergrund ist, dass ich aus einem unstrukturierten Text eine Artikelnummer filtern muss. Gibt es eine Möglichkeit, in einemText die Stelle zu bestimmen, in dem die erste Ziffer vorkommt?
Danke schon mal im Voraus!
Gruss Florian

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
Position der ersten Ziffer im Text
29.01.2011 12:23:24
WF
Hi Floriab,
folgende Arrayformel:
{=VERGLEICH(WAHR;ISTZAHL(TEIL(A1;ZEILE(1:99);1)*1);)}
ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter (statt Enter allein); - das erzeugt sie.
Salut WF
AW: Finde bel. Zahl in Text
29.01.2011 17:27:53
Erich
Hi Florian,
liefert FINDEN nicht genau die Position, die du möchtest?
 ABC
1Artikelnrab Stellein Text
2471181554In diesem Text kommt hinter 471181 auch die gesuchte 4711815 vor.
34711829In diesem Text kommt hinter 471181 auch die gesuchte 4711815 vor.

ZelleFormel
B2=FINDEN(A2;C2)
B3=FINDEN(A3;C3)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Anzeige
Sorry - Rückzug
29.01.2011 17:42:48
Erich
Hi Florian,
da hatte ich deine Frage gründlic h mjissverstanden...
Schönes WoEnde und Grüße von Erich aus Kamp-Lintfort
Vielen Dank an alle (oT)
30.01.2011 10:10:06
Florian
..

328 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige