Microsoft Excel

Herbers Excel/VBA-Archiv

Text(?) in zZahl wandeln geht nicht


Betrifft: Text(?) in zZahl wandeln geht nicht von: Peter
Geschrieben am: 06.07.2018 15:32:00

Hallo zusammen,

ich verzweifel.

Es gelingt mir nicht eine aus einer eMail in Excel 2010(engl) kopierte Zahlengruppe in echte Zahlen zu wandeln.
Ich habe es versucht mit den Excel-Funktionen
=value(Zelle)
=numbervalue(Zelle)
=--links(Zelle;2)
Ergebnis jedesmal: #value!
auch der Weg über Paste Special und Operations "Add" mit 0 und "multiply" mit 1
brachte kein Ergebnis.
Wo liegt mein Fehler?

hier der link zur Tabelle
https://www.herber.de/bbs/user/122512.xlsx

P.S. in der Tabelle wurde Zelle D2 als text formatiert und dann die Ziffer 7 eingegeben, um die Formeln zu testen. Alle anderen "Zahlen" sind aus der email

  

Betrifft: AW: Text(?) in zZahl wandeln geht nicht von: Daniel
Geschrieben am: 06.07.2018 15:58:20

Hi
die Texte enthalten am Anfang noch zweimal ein seltsames Zeichen.
wenn man es mit Code analysiert, wird das Zeichen 63, Fragezeichen ausgeworfen, aber das ist es offentsichtlich nicht.
VBA ermittelt den erweiterten ASCII-Cose 8205, was immer das ist. Excel kann es nicht anzeigen, aber es ist da und verhindert die umwandlung in Zahlen

die Umwandlung kanst du mit der Formel =Wert(Teil(D3;3;2)) / =Value(Mid(D3,3,2)) durchführen.

Gruß Daniel


  

Betrifft: AW: Text(?) in zZahl wandeln geht nicht von: mmat
Geschrieben am: 06.07.2018 16:02:01

Hallo Peter,

aus unerfindlichen Gründen befindet sich vor den Zahlen der Text "??", der aber nicht sichtbar ist. Frag mal die Längen der Zellen ab (=Länge(zelle)), dann siehste das da was nicht stimmt.

Versuche =wert (Teil(Zelle; 3; 99))


  

Betrifft: AW: Text(?) in zZahl wandeln geht nicht von: Peter
Geschrieben am: 06.07.2018 16:10:31

Super! vielen Dank!!! :-)
wäre ich nie drauf gekommen, die Länge abzufragen.
LG
Peter


  

Betrifft: AW: Text(?) in zZahl wandeln geht nicht von: UweD
Geschrieben am: 06.07.2018 16:26:03

Hallo



Wenn alle Zellen noch ursprünglich sind dann so...


Sheet1

 O
922

verwendete Formeln Englisch
Zelle Formel Bereich N/A
O9=SUBSTITUTE(D9,LEFT(D9,1),"")  
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.14 einschl. 64 Bit





LG UweD


  

Betrifft: natürlich mit -- von: UweD
Geschrieben am: 06.07.2018 16:27:44


Sheet1

 O
922

verwendete Formeln Englisch
Zelle Formel Bereich N/A
O9=--SUBSTITUTE(D9,LEFT(D9,1),"")  
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.14 einschl. 64 Bit




  

Betrifft: AW: Text(?) in zZahl wandeln geht nicht von: UweD
Geschrieben am: 06.07.2018 16:31:51

Oder direkt so..


=WENNFEHLER(--WECHSELN(D2;LINKS(D2;1);"");--D2)

=IFERROR(--SUBSTITUTE(D2,LEFT(D2,1),""),--D2)


LG UweD


Beiträge aus dem Excel-Forum zum Thema "Text(?) in zZahl wandeln geht nicht"