Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Aus Text Minusstunden in Deziamalzahl

Aus Text Minusstunden in Deziamalzahl
20.12.2012 00:13:03
Norbert
Hallo Excelfreunde,
Ich suche eine Formel mit der ich Minusstunden, die als Text vorliegen, in eine Dezimalzehl umwandeln kann.
Beispiel
aus -24:28:30 soll dann werden -24,475
habe schon einiges probiert, viel gegooglet, aber nix passendes gefunden
das datumsformat 1904 möchte ich nur ungern verwenden.
Vielen Dank im Vorraus und Grüße aus München
Norbert

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Negative Zeiten
20.12.2012 01:03:49
Beate
Hallo Norbert,
um mit positiven und negativen Zeiten arbeiten zu können:
 AB
1Format
2TextZahl mit 3 Dezimalstellen
3-24:28:30-24,475
424:28:3024,475

Formeln der Tabelle
ZelleFormel
B3=WENN(LINKS(A3;1)="-";("-"&TEIL(A3;2;99)*24)*1;A3*24)

Die Formel aus B3 kann runterkopiert werden.
Guckst Du: Negative Zeiten
Gruß,
Beate

Anzeige
AW: Negative Zeiten
20.12.2012 01:20:11
Norbert
genau was ich gesucht habe
frohes Weihnachtsfest
Norbert

Negative Zeiten
20.12.2012 01:26:50
Beate
Hallo Norbert,
hier noch etwas kürzer, was auch geht:
 AB
1Format
2TextZahl mit 3 Dezimalstellen
3-24:28:30-24,475
424:28:3024,475

Formeln der Tabelle
ZelleFormel
B3=WENN(LINKS(A3;1)="-";(TEIL(A3;2;99)*-24); A3*24)

Die Formel aus B3 kann runterkopiert werden.
Gruß und Frohe Weihnachtstage,
Beate

Anzeige
:-) vielen Dank
20.12.2012 01:33:00
Norbert
Werde geleich morgen damit weiterarbeiten, denn nun habe ich Schichtende.
Feut mich, dass Nachts auch Ex(cel)pertinen unterwegssind. das Problem hat mich schon so manche Stunde gekostet.
Nochmals Viele Grüße
Norbert

noch eine kleine Verkürzung
20.12.2012 01:42:58
Beate
Hallo Norbert,
ich habe bemerkt, ich habe noch ein überflüssiges Klammerpaar eingebaut. Also dann kürzer so:
 AB
1Format
2TextZahl mit 3 Dezimalstellen
3-24:28:30-24,475
424:28:3024,475

Formeln der Tabelle
ZelleFormel
B3=WENN(LINKS(A3;1)="-";TEIL(A3;2;99)*-24;A3*24)

Die Formel aus B3 kannst du runterkopieren.
Gruß,
Beate

Anzeige
=WECHSELN(A1;"-";)*((N(A1)>0)*2-1)*24
20.12.2012 08:51:23
Mäxl
Hi,
wünsche auch noch schöne Feiertage
lg
Mäxl

LINKS(A3) ist dasselbe wie LINKS(A3;1)
20.12.2012 08:52:55
WF
.

350 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige