Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

gleiche Texteinträge in mehreren Spalten zählen

gleiche Texteinträge in mehreren Spalten zählen
11.10.2017 09:06:36
Katja
Hallo zusammen,
ich bin gerade an einer Excel-Auswertung und möchte Teile von Texteinträge in mehreren Spalten zählen. In den Spalten stehen identische Texteinträge und es soll immer nur der erste Eintrag in der jeweiligen Zeile gezählt werden. Kann mir hier jemand weiterhelfen?
https://www.herber.de/bbs/user/116867.xlsx

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Sag uns das Ergebnis für Zeilen 2:5 - owT
11.10.2017 09:13:28
lupo1
gleiche Texteinträge in mehreren Spalten zählen
11.10.2017 09:33:08
Katja
Also in den Zeilen soll z. B. der Texteintrag "*aureus*" gezählt werden.
Ergebnis Zeile 2= 0
Ergebnis Zeile 3= 0
Ergebnis Zeile 4= 1
Ergebnis Zeile 5= 0
Ich muss da ganze auch für alle anderen Texteinträge z. B. den Texteintrag "*faecium*" machen
Ergebnis Zeile 2=0
Ergebnis Zeile 3=1
Ergebnis Zeile 4=0
Ergebnis Zeile 5=1
Siehst ein, dass AUREUS + FAECIUM "Glaskugel" war?
11.10.2017 09:42:02
lupo1
... und danach?
Wo ist die Liste mit den Suchbegriffen?
Ergebnis
11.10.2017 10:00:10
lupo1
H2: aureus
I2: =SUMMENPRODUKT(--ISTZAHL(SUCHEN(H2;D$1:D$56&E$1:E$56&F$1:F$56&G$1:G$56)))
AW: Ergebnis
11.10.2017 15:39:13
Katja
Vielen Dank für die Formel. Hat alles bis jetzt funktioniert!
Anzeige
AW: wenn mehr als 4 Spalten auszuwerten sind ...
11.10.2017 20:15:08
...
Hallo Katja,
... könnte die Formel etwas aufwendig werden. Dafür dann folgende alternative Formellösung für Daten in Spalten D:Z und "aureus" in AA2:
=-SUMME(INDEX(-(MMULT(-ISTZAHL(SUCHEN(AA2;D$1:Z$99));ZEILE(A1:A23))
Die A23 in ZEILE(A1:A23)ist abhängig von der letzten auszuwertenden Spalte und zwar so: = _ SPALTE(Z1)-SPALTE(D1)+1=23 wie =SPALTE(G1)-SPALTE(D1)+1=4 ist und somit für Daten in Spalte D:G

=-SUMME(INDEX(-(MMULT(-ISTZAHL(SUCHEN(AA2;D$1:G$99));ZEILE(A1:A4))
Gruß Werner
.. , - ...
Anzeige

387 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige