Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Anzahl Text in Spalte mit Bedingung

Anzahl Text in Spalte mit Bedingung
15.02.2019 11:09:49
Peter
Hallo ihr Excelspezialisten,
in einer Spalte B (B2:B65656) werden Namen aufgelistet. In der Spalte H wird je nachdem
ein Wert (Datum) oder leer aufgelistet.
Ich bräuchte nun eine Formel, welche mir die Anzahl auflistet, wenn in der Spalte ein bestimmtes Wort (z. B. Test) nicht berücksichtigt wird und auch nur die Werte in denen in der Spalte H leer ist.
Bisher löse ich dies indem ich die Werte welche vorkommen können in der Hilfstabelle aufliste und dann mit der Formel:~~f =ZÄHLENWENN(Kontodaten!B2:B65656;A2) die Anzahl je Namen ermittle und dann in einer separaten Zelle mit der Formel:~f~ =SUMMENPRODUKT((B3:B65656>1)*(Kontodaten!H3:H65656="")) die Anzahl der restlichen Namen ermittle.
Wenn jedoch der Name ("Test) nochmals auftaucht funktioniert die Formel nicht mehr.
Besten Dank für eure Hilfe.
Gruss

12
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Anzahl Text in Spalte mit Bedingung
15.02.2019 11:14:11
SF
Hola,
=zählenwenns(Kontodaten!B2:B65656;A2;Kontodaten!H2:H65656;"";M2:M65656;"test")

Gruß,
steve1da
AW: Anzahl Text in Spalte mit Bedingung
15.02.2019 11:33:37
Peter
Hallo Steve,
besten Dank für Deine Hilfe.
Aber wie kommst Du auf Spalte M?
Gruss
Peter
AW: Anzahl Text in Spalte mit Bedingung
15.02.2019 11:41:59
SF
Hola,
sorry, sollte Spalte B sein.
Gruß,
steve1da
AW: Anzahl Text in Spalte mit Bedingung
15.02.2019 12:00:35
Peter
Hallo Steve,
funktioniert leider nicht.
In der Spalte B sind insgesamt 8 Wörter, davon 3 mal "Test".
In der Spalte H sind die ersten 5 Zellen nicht leer, die nächsten 3 sind "leer".
Davon sind aber in Spalte B 2 Wörter mit Spalte H = "" und 1 mit Wort "Test" und Spalte H ="".
Es sollte aber als Ergebnis "2" nicht "3" erscheinen.
Was ist hier bitte nicht richtig?
Gruss
Peter
Anzeige
AW: Anzahl Text in Spalte mit Bedingung
15.02.2019 12:08:34
SF
Hola,
ohne deine Datei kann ich leider nicht sagen was falsch ist.
Gruß,
steve1da
AW: Anzahl Text in Spalte mit Bedingung
15.02.2019 12:14:35
Peter
Hallo Steve,
aber ich kann Dir zwischenzeitlich sagen was an der Formel falsch ist:
Der Fehler liegt darin nicht "<>Test" sondern "<Test".
Besten Dank für Deine Hilfe.
Gruss
Peter
AW: Anzahl Text in Spalte mit Bedingung
15.02.2019 12:17:07
SF
Hola,
dann sollte test auch funktionieren. Sei's drum ;-)
Gruß,
steve1da
AW: Anzahl Text in Spalte mit Bedingung
15.02.2019 13:05:35
Peter
Hallo Steve,
das Ganze funktioniert nicht - Deine und auch meine Formel.
Ich füge nun eine Musterdatei bei:
https://www.herber.de/bbs/user/127681.xlsx
Vielleicht kannst Du Dir das nochmals ansehen.
Besten Dank
Gruss
Peter
Anzeige
AW: Anzahl Text in Spalte mit Bedingung
15.02.2019 13:14:24
SF
Hola,
du suchst in Spalte B nach dem Wort aus J2, das lautet "test". Es soll aber gleichzeitig nicht gezählt werden, wenn "test" in Spalte B steht.
Das kann nur 0 ergeben.
Gruß,
steve1da
AW: Anzahl Text in Spalte mit Bedingung
15.02.2019 13:18:19
Peter
Hallo Steve,
ich möchte alle Zellen in Spalte B zählen, welche nicht das Wort "test" beinhaltet und bei denen die Werte in Spalte H "" sind. Die Spalte H ist auf Datum formatiert.
Gruss
Peter
AW: Anzahl Text in Spalte mit Bedingung
15.02.2019 13:22:25
SF
Hola,
=ZÄHLENWENNS(B:B;"test";H:H;"";B:B;"")

Gruß,
steve1da
AW: Anzahl Text in Spalte mit Bedingung
15.02.2019 13:26:21
Peter
Hallo Steve,
Super! Jetzt funktioniert es einwandfrei.
Vielen Dank und noch einen schönen Tag.
Gruss
Peter
Anzeige

346 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige