Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Duplikate in Spalte auszählen

Duplikate in Spalte auszählen
der
Guten Morgen zusammen,
ich habe eine Tabelle mit mehreren Spalten.
Eine Spalte enthält Schlüsselnummern, welche auch „doppelt“ vorkommen können.
Die Nummern bestehen aus einer Hauptnummer (wilkürlich) / Nebennummer (aufsteigend)
Bsp: 000000000/000.
Wie bekomme ich es hin, nur die Hauptnummern auszählen?
Echte (absolut identische) Duplikate auszählen bekomme ich ohne Probleme hin… Aber hier bin ich ratlos, da meine Formeln nicht fuktionieren.
Bsp:
00000815/001
00000815/002
00000815/003
00000816/001
00000816/002
00000817/001
00000817/002
00000817/003
00000817/004
00000818/001
00000818/002
00000818/003
usw.
v.G. der Vati

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
kleine Arrayformel
15.08.2011 10:29:25
WF
Hi,
die Anzahl soli der Hauptnummern ist:
{=SUMME(WENN(A1:A99"";VERGLEICH(LINKS(A1:A99;8);LINKS(A1:A99;8);0)=ZEILE(1:99))*1)}
die Duplikate ergo:
Anzahl2(A1:A99) minus obige Formel
Salut WF
siehe:
http://www.excelformeln.de/formeln.html?welcher=42
AW: Arrayformel funktioniert nicht mit INDIREKT
15.08.2011 12:21:44
der
Hallo WF,
Vielen Dank, für deine Hilfe.
Ich konnte die Formel soweit für meine Bedürfnisse anpassen.
{=SUMME(WENN(September!B1:B1000"";VERGLEICH(LINKS(September!B1:B1000;8);LINKS(September!B1:B1000;8) ;0)=ZEILE(September!1:1000))*1) -1}
Nun scheitere ich aber daran den Bereich: September!B1:B1000, mit einem dynamischen Sheet-Namen zu ersetzen.
Ich habe quasi 12 Monats- Sheets und wähle in meiner Gesamtübersicht, per Dropdown (in $B$8)den Monat aus.
Der augewählte Monat soll nun per: INDIREKT("'"&$B$8&"'!$B1:$B1000") anstatt: September!B1:B1000
dynamisch in der Formel integriert werden.
Das klappt bei allen anderen Formel auch wunderbar. Nur Bei der oben stehenden nicht.
Kann mir hier bitte noch einmel jemand weiter helfen?
V.G. der Vati
Anzeige
mit INDIREKT: nullo problemo
15.08.2011 12:36:13
WF
Hi,
Du hast Deine Formel nicht vollständig gezeigt - da ist irgendwas falsch !
Das z.B. funktioniert:
{=SUMME(WENN(INDIREKT(A5&"!A1:A99")"";VERGLEICH(LINKS(INDIREKT(A5&"!A1:A99");8); LINKS(INDIREKT(A5&"!A1:A99");8);0)=ZEILE(1:99))*1) }
Salut WF
AW: klappt super :)
15.08.2011 13:23:00
der
Hallo WF,
Vielen Dank, jetzt passt erstmal alles.
Mit dieser Formel zählt er mir alles aus:
{=SUMME(WENN(INDIREKT($B$8&"!$b$2:$b$1000")"";VERGLEICH(LINKS(INDIREKT($B$8&"!$b$2:$b$1000");8); LINKS(INDIREKT($B$8&"!$b$2:$b$1000");8);0)=ZEILE(1:999))*1) }
Danke und Gruß
der Vati
oder so
15.08.2011 15:21:53
ingoG
Hallo zusammen,
wenn die Daten immer durchnummeriert sind und mit 001 anfangen, gehts auch so:
=ZÄHLENWENN(INDIREKT(A5&"!A1:A1000");"*/001")
Gruß Ingo
PS eine Rückmeldung wäre nett...
Anzeige
bestimmt nicht
15.08.2011 16:03:33
WF
wenn .../001 mehrfach bei gleicher Basiszahl auftaucht (also Doppler gesamt), gibt's Müll.
WF
AW: bestimmt nicht
15.08.2011 17:38:47
ingoG
Hallo WF,
danke für den Hinweis.
Wenn die Doppler vorkommen, dann hast Du natürlich recht,
wenn aber nicht, wäre die Formel so viel einfacher und schneller ...
Gruß Ingo

322 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige