ZählenwennS in verschiedenen Spalten?

Bild

Betrifft: ZählenwennS in verschiedenen Spalten?
von: Kalle
Geschrieben am: 01.07.2015 00:17:27

Hallo,
suche schon seit Tagen nach einer Lösung.. Habe folgendes Problem
möchte 2 SpaltenBereiche zählen, wenn eine Zelle der Spalte 2 leer ist. So ist es kein Problem. Nehme hierfür "=ZählenwennS(A2:A9;"TL";B2:B9;"""), aber jetzt möchte ich nicht immer die Spalte 2 sondern flexibel eine Spalte verwenden. Sozusagen einen Suchwert verwenden den ich in eine Zelle eingebe, in welche Spalte er gehn soll um zu zählen... dachte da an S- oder Wverweis aber ich bekomm es einfach nicht zusammen.. HILFE!!!. Bitte kein VBA Code.
Spalte1 //Spalte2 // Spalte3 //// usw... spalte4/5/6/7
Bereich //1/2/2015 //1/3/2015
TL // xx // U
TL // U // U
TL // 1//K
Ul
RO
Ul U
PD K
TL

Bild

Betrifft: AW: ZählenwennS in verschiedenen Spalten?
von: Mullit
Geschrieben am: 01.07.2015 01:10:12
Hallo,
Bereich.Verschieben geht dafür ganz gut, hab aber hier nur xl2007 vielleicht gibt's in xl2010 noch andere Möglichkeiten:

 ABCDEFGHI
1        4
2TLfhhfuiuiz zuiuft    
3TLfgh  fdggjghjhgj   
4TLhf  ghjg    
5TL  zuiuhjkhgjghhjg   
6TL   fhjg    
7TLfghfghzuizui jghghjghj 4 
8TL        
9TLfhg zuuiz jjghjg   
10TLfhfhggfzuizuii  ghjgjgh   
11TL        

ZelleFormel
H7=ZÄHLENWENNS($A$2:$A$9;"TL"; BEREICH.VERSCHIEBEN($B$2:$B$9;0;$I$1);"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Gruß, Mullit

Bild

Betrifft: AW: ZählenwennS in verschiedenen Spalten?
von: Kalle
Geschrieben am: 01.07.2015 01:47:17
Das funzt ja schon mal ganz gut, möchte aber ein Datum eingeben das sich auf eine Spalte bezieht...

Bild

Betrifft: AW: ZählenwennS in verschiedenen Spalten?
von: Mullit
Geschrieben am: 01.07.2015 02:17:39
na dann, viel Spaß, ist doch easy, mehr Salami gibt's aber nicht für's Butterbrot...

 ABCDEFGHI
1        01.05.2015
2TLfhhfuiuiz zuiuft    
3TLfgh  fdggjghjhgj   
4TLhf  ghjg    
5TL  zuiuhjkhgjghhjg   
6TL   fhjg    
7TLfghfghzuizui jghghjghj 4 
8TL        
9TLfhg zuuiz jjghjg   
10TLfhfhggfzuizuii  ghjgjgh   
11TL        

ZelleFormel
H7=ZÄHLENWENNS($A$2:$A$9;"TL"; BEREICH.VERSCHIEBEN($B$2:$B$9;0;MONAT($I$1)-1);"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Bild

Betrifft: AW: ZählenwennS in verschiedenen Spalten?
von: Kalle
Geschrieben am: 01.07.2015 02:22:29
Vielen Dank!! Du bist meine Rettung und einfach nur der Hammer!!!

Bild

Betrifft: Excel 2010 bedaf es nicht, um INDEX() zu nutzen...
von: der neopa C
Geschrieben am: 01.07.2015 09:47:12
Hallo Mullit,
... damit nehme ich Bezug auf Deine Aussage: "Bereich.Verschieben geht dafür ganz gut, hab aber hier nur xl2007 vielleicht gibt's in xl2010 noch andere Möglichkeiten",
denn INDEX() würde ich hier der volatile Funktion BEREICH.VERSCHIEBEN() vorziehen.
Hier einfach: =ZÄHLENWENNS($A$2:$A$9;"TL";INDEX($B$2:$G$9;;I1+1);"")
Analog geht das natürlich auch mit einem Datumswert oder ... auch zusätzlich mit VERGLEICH()
Anstelle SUMMEWENNS() könnte auch SUMMENPRODUKT() eingesetzt werden und damit wäre die Auswertung genau so einfach auch in früheren Excelversionen möglich:
=SUMMENPRODUKT(($A$2:$A$9="TL")*(INDEX($B$2:$G$9;;I1+1)=""))
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Excel 2010 bedaf es nicht, um INDEX() zu nutzen...
von: Mullit
Geschrieben am: 01.07.2015 20:24:12
Hallo Werner,
ist natürlich richtig, ich hatte die Index_Variante inspiriert von diesem Artikel auch noch angelegt, dachte mir aber, bei geringerem Formelvolumen reicht um die Uhrzeit erstmal eine Lösung, danke aber für die Tipps, es ist natürlich immer gut die Varianten zu kennen...
Gruß, Mullit

 Bild

Beiträge aus den Excel-Beispielen zum Thema "ZählenwennS in verschiedenen Spalten?"