Microsoft Excel

Herbers Excel/VBA-Archiv

zählenwenn, 2 Bedingungen in Spalte und Zeile

Betrifft: zählenwenn, 2 Bedingungen in Spalte und Zeile von: Hans
Geschrieben am: 05.09.2014 14:00:13

Hallo Forum,

in der beiliegenden Musterdatei habe ich folgendes Problem.
Ich möchte die Anzahl der Tage, an denen nur Samstags gearbeitet wurde.

Ich habe folgende Formel versucht zum Laufen zu bekommen, jedoch ohne Erfolg.

=ANZAHL(WENN((B4:AA4=6)*(B2:AA2="Sa");1))
' die 6 habe ich gewählt, um überhaupt in die richtige Richtung zu kommen, jedoch ohne Erfolg.

Aussagen will ich folgendes:

wenn in der zeile B4 bis AA4 ein Zahlenwert steht und dazu passend in der Zeile B2 bis AA2 das Wort "Sa" enthalten ist, sage mir wie oft der Fall vorkommt (Anzahl2).
Außerdem möchte ich dann noch die Gesamtstunden von der Samstagsarbeit haben.

Hier der Link zur Musterdatei:
https://www.herber.de/bbs/user/92496.xlsx

  

Betrifft: AW: zählenwenn, 2 Bedingungen in Spalte und Zeile von: Robert
Geschrieben am: 05.09.2014 14:11:13

Hallo Hans

=ZÄHLENWENNS(B4:AA4; ">0"; B1:AA1; "=Sa")
Viele Grüße
Robert


  

Betrifft: AW: zählenwenn, 2 Bedingungen in Spalte und Zeile von: rene
Geschrieben am: 05.09.2014 17:33:20

.


  

Betrifft: AW: zählenwenn, 2 Bedingungen in Spalte und Zeile von: Robert
Geschrieben am: 05.09.2014 14:12:51

Summe der SamstagsArbeit:

SUMMEWENNS(B4:AA4; B1:AA1; "=Sa")



 

Beiträge aus den Excel-Beispielen zum Thema "zählenwenn, 2 Bedingungen in Spalte und Zeile"