VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Zeilen zählen, in denen zwei Bedingungen zutreffen

Gruppe

Matrix

Bereich

Matrixfunktion

Thema

Zeilen zählen, in denen zwei Bedingungen zutreffen

Problem

In Zelle A1 sollen die Zeilen gezählt werden, in denen beide in der Formel genannten Bedingungen erfüllt sind.

Lösung

Folgende Matrixformel: =SUMME((E1:E1000=0)*(G1:G1000=2)*1)




ClassModule: Tabelle1

Private Sub spnRows_Change()
   ActiveCell.Select
   If spnRows.Value = 0 Then
      Rows("1:20").Hidden = False
   Else
      Rows("1:" & spnRows.Value).Hidden = True
      Rows(spnRows.Value + 1 & ":20").Hidden = False
   End If
End Sub

Private Sub spnColumns_Change()
   ActiveCell.Select
   If spnColumns.Value = 0 Then
      Columns("A:Z").Hidden = False
   Else
      Range(Cells(1, 1), Cells(1, spnColumns.Value)). _
         EntireColumn.Hidden = True
      Range(Cells(1, spnColumns.Value + 1), Cells(1, 256)). _
         EntireColumn.Hidden = False
   End If
End Sub

    


Beiträge aus dem Excel-Forum zu den Themen Matrix und Matrixfunktion