Microsoft Excel

Herbers Excel/VBA-Archiv

matrixformel gesucht

Betrifft: matrixformel gesucht von: barbara_w
Geschrieben am: 11.07.2008 21:51:04

hallo

habe folgendes problem:
in spalte A stehen hundert beliebige einträge untereinander.
ebenso in Spalte B
gesucht ist eine formel, die 1 ergibt, wenn keine nebeneinanderstehende werte gleich sind.
also wenn die werte so aussehen

spalte A......spalte B
hund.......katze
sonne......mond
15...........16
usw.

wenn aber sowas wie
hund......hund
oder
15.........15
also irgendwo in den hundert zeilen 2 GLEICHE einträge nebeneinander mindestens vorkommen,
soll die Formel 0 ergeben.

geht das vielleicht mit einer matrix-formel?

lg
barbara

  

Betrifft: AW: matrixformel gesucht von: Caruso
Geschrieben am: 11.07.2008 22:00:52

Hallo Barbara,

eine mögliche Formel ist

=(MIN(1;SUMMENPRODUKT(--(A1:A100=B1:B100)))-1)*-1



Gruß

Carlo


  

Betrifft: AW: matrixformel gesucht von: barbara_w
Geschrieben am: 11.07.2008 22:34:53

ihr seid einfach genies.

Uduuh, danke auch dir für deine hilfe.

carlo, hab mal versucht, deine formel zu verstehen.
Sind meine Interpretationen so richtig?

was bedeuten die beiden minus?
damit wird WAHR und FALSCH in 1 und null umgewandelt

Warum SUMMENPRODUKT und nicht SUMME?
Weil man dann keine Matrixformel braucht.

lg
barbara


  

Betrifft: AW: matrixformel gesucht von: Caruso
Geschrieben am: 11.07.2008 22:53:18

Hallo Barbara,

zu beiden Interpretationen: sind korrekt und Verwendung nach persönlicher Vorliebe

SUMMENPRODUKT(--(A1:A100=B1:B100)) entspricht SUMMENPRODUKT(-1*-1*(A1:A100=B1:B100)) entspricht SUMMENPRODUKT(1*(A1:A100=B1:B100)) - die Zeitersparnis für das Eintippen von "--" gegenüber "1*" ist vernachlässigbar und nicht der Grund ;-)

ob Summenprodukt(...) oder {Summe(...)} - reine Gewohnheit und in 99% der Fälle kann das Problem durch beide Funktionen gelöst werden.


Gruß

Carlo


  

Betrifft: AW: matrixformel gesucht von: barbara_w
Geschrieben am: 11.07.2008 22:55:19

Einfach genial.

hab wieder was dazu gelernt.

Danke.

LG
Barbara


  

Betrifft: AW: matrixformel gesucht von: Uduuh
Geschrieben am: 11.07.2008 22:05:49

Hallo,
{=SUMME((A1:A100=B1:B100)*1)}

Gruß aus’m Pott
Udo



 

Beiträge aus den Excel-Beispielen zum Thema "matrixformel gesucht"