Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema ListBox
BildScreenshot zu ListBox ListBox-Seite mit Beispielarbeitsmappe aufrufen

Gesamtsumme und Einzelsumme in Matrix

Betrifft: Gesamtsumme und Einzelsumme in Matrix von: Georg
Geschrieben am: 14.03.2008 16:19:37

Hallo Excel Welt,

ich will in einer dropdown gesteuerten Matrixformel nicht nur die Werte zu den einzelnen Bedingungen gezeigt bekommen, sondern ich will mir neben den Einzelwerten auch die Gesamtsumme anzeigen lassen können.
Ich habe dazu eine kleine Musterdatei hochgeladen (https://www.herber.de/bbs/user/50743.xls
). Hier habe ich Umsätze pro Monat und Team. Mit der Matrix kann ich mir jetzt die Umsätze entweder für das eine oder andere Team auswählen (Auswahl in Zelle G1). Ich kann aber nicht die Summe der Umsätze beider Teams auswählen. Dazu müsste ich ihm sagen können, summiere nicht Team 1 oder 2 sondern alle Daten die (zu dem Monat) bereitgestellt werden ( 15+16=31).
Im Dropdown müsste ich also einen Wert (wie auch immer) dafür angeben können nach dem Motto: "ignoriere den Filter" oder "nimm alles in der Spalte". Und daran scheitere ich. Geht das überhaupt?
Danke und Gruß
Georg

  

Betrifft: AW: Gesamtsumme und Einzelsumme in Matrix von: fcs
Geschrieben am: 14.03.2008 17:07:09

Hallo Georg,

stelle deine Matrix-Formel ein wenig um:

=SUMME(WENN(H$3=$A$2:$A$25;WENN(($G$1="")+($G$1=$B$2:$B$25);$C$2:$C$25)))


Wenn Zelle G1 leer ist werden alle Teams summiert. Das +Zeichen entspricht hier der ODER Verknüpfung der beiden Bedingungen.

Etwas einfacher ist es ggf. wenn du die Daten mit einem Pivot-Tabellenbericht auswertest.

Gruß
Franz


  

Betrifft: Super, klappt perfekt!! owT von: Georg
Geschrieben am: 14.03.2008 17:23:58

.


 

Beiträge aus den Excel-Beispielen zum Thema "Gesamtsumme und Einzelsumme in Matrix"