Microsoft Excel

Herbers Excel/VBA-Archiv

Matrix-Erstellung mit Excel - Hilfe!?

Betrifft: Matrix-Erstellung mit Excel - Hilfe!? von: Andreas
Geschrieben am: 27.06.2008 09:11:24

Hallo,

ich möchte die Häufikeit von zusammen auftretenden Schlagwörtern aus Dokumenten in eine sog. Co-Occurance Matrix übertragen (s. Anhang).

Die Datenerfassung findet mit Excel statt. Ich suche nun eine geeignete Formel oder VBA-Anwendung, die mir erlaubt eine solche Matrix schnell und einfach aus den Daten aufzustellen (s. Anhang).

Ich verzweifel... Momentan ist in meinem Kopf 2+2=5 ;-)

Kann mir jemand dabei helfen? Hier die Vorlage: https://www.herber.de/bbs/user/53385.xls

Andreas

  

Betrifft: AW: Matrix-Erstellung mit Excel - Hilfe!? von: Klaus M.vdT.
Geschrieben am: 27.06.2008 09:28:28

Hallo Andreas,

Diese Formel in C43:

=SUMMENPRODUKT((C$5:C$37=C$42)*(BEREICH.VERSCHIEBEN($B$5:$B$37;0;VERGLEICH($B43;$C$42:$H$42;))=$B43))

und nach rechts sowie unten kopieren.

Grüße,
Klaus M.vdT.


  

Betrifft: AW: Matrix-Erstellung mit Excel - Hilfe!? von: Andreas
Geschrieben am: 27.06.2008 10:22:22

Toll! Vielen Dank! Das funktioniert Klasse!

Ich bin ein bißchen unter Zeitdruck. Habt ihr vielleicht eine einfache Idee wie man folgendes Problem einer Matrixaufstellung gelöst bekommt?

https://www.herber.de/bbs/user/53397.xls

Grüße,

Andreas


  

Betrifft: AW: Matrix-Erstellung mit Excel - Hilfe!? von: David
Geschrieben am: 27.06.2008 10:53:52

so?

https://www.herber.de/bbs/user/53400.xls

Gruß

David


  

Betrifft: AW: Matrix-Erstellung mit Excel - Hilfe!? von: David
Geschrieben am: 27.06.2008 10:56:51

Nachtrag.

Wenn du den Bereich J21:N25 markierst und dort als bedingte Formatierung "=J$20=$I21" eingibst, das dann als FETT definierst, sind die entsprechenden 0-Werte noch fett markiert.

Gruß

David


  

Betrifft: Ihr seid großartig! Danke! von: Andreas
Geschrieben am: 27.06.2008 15:35:38



Klaus, David - Vielen Dank für die Hilfe! Das hat mich einen großen Schritt weiter gebracht.

Grüße, Andreas


  

Betrifft: AW: Matrix-Erstellung mit Excel - Hilfe!? von: Andreas
Geschrieben am: 27.06.2008 19:05:12

Eine Sache noch: Die Zeilen und Spalten der Matrix sollen auch Text enthalten können. Habt Ihr dafür auch eine Lösung?

Beispiel im Anhang: https://www.herber.de/bbs/user/53415.xls

Gruß, Andreas


  

Betrifft: Danke für die Rückmeldung! o.w.T. von: Klaus M.vdT.
Geschrieben am: 27.06.2008 11:54:43

.