Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema ListBox
BildScreenshot zu ListBox ListBox-Seite mit Beispielarbeitsmappe aufrufen

Matrix Formel mit Textfeldern

Betrifft: Matrix Formel mit Textfeldern von: Susi
Geschrieben am: 15.05.2008 10:55:35

Hallo,

ich habe hier im Moment ein Problem wo ich keine Lösung zu finde

Ich möchte über eine Matrixformel eine Spalte summieren in welcher dummerweise zwischendrin Textfelder stehen.

Wert Kriterium
1 a
2 a
abc
5 a
4 a
abc
ybc

=SUMME((B3:B9="a")*(A3:A9)) (Die Matrixklammern müsst Ihr Euch dazu denken).

Hat Hier jemand vielleicht eine Idee? Die Formel soll so flexibel sein, dass man bei Veränderungen der Zeilenstruktur nicht die Formel anpassen muß.

Liebe Grüße

Susi


  

Betrifft: =SUMMEWENN(B3:B9;"a";A3:A9) von: WF
Geschrieben am: 15.05.2008 11:00:22

Hi Susi,

bei nur einem Kriterium brauchst Du keine Matrixformel.

Salut WF


  

Betrifft: AW: =SUMMEWENN(B3:B9;"a";A3:A9) von: Uwe (:o)
Geschrieben am: 15.05.2008 11:07:21

Hi Susi,
WF hat natürlich recht, daran hatte ich gar nciht gedacht. Ich hatte diese Matrixformel zusammengebastelt:
{=SUMME((B3:B9="a")*(WENN(ISTZAHL(A3:A9);(A3:A9);0)))}
Funktioniert auch und ist dann auch für mehr spalten ausbaufähig.
(Aber vielleicht geht es sogar einfacher?)

Gruß
Uwe
(:o)


  

Betrifft: einfacher durch WENNEN von: WF
Geschrieben am: 15.05.2008 11:12:25

Hi Susi + Uwe,

{=SUMME(WENN(B3:B9="a";A3:A9))}

Salut WF


  

Betrifft: Mit mehreren Kriterien WENNEN von: WF
Geschrieben am: 15.05.2008 11:54:00

{=SUMME(WENN(B3:B9="a";WENN(C3:C9="b";A3:A9)))}


  

Betrifft: mehrere Kriterien ohne zu WENNEN von: heikoS
Geschrieben am: 15.05.2008 12:13:17

Hallo zusammen,

{=SUMME((B3:B9="a")*(C3:C9="b")*(A3:A9))}


Gruß Heiko


  

Betrifft: es geht nur mit WENN, von: WF
Geschrieben am: 15.05.2008 12:24:46

wenn in Spalte B oder C auch Text vorkommt.

Das war das Thema dieses threads.

Wer lesen kann, hat Vorteile
Salut WF


  

Betrifft: ups von: heikoS
Geschrieben am: 15.05.2008 12:55:30

Hallo Walter,

da hatte ich doch die Ursprungsfrage nicht richtig gelesen... tststs.


Gruß Heiko


  

Betrifft: AW: =SUMMEWENN(B3:B9;"a";A3:A9) von: Susi
Geschrieben am: 15.05.2008 11:16:58

Danke! Uwe hat die Lösung gehabt. Ich habe mehr als ein Kriterium!

Jetzt funktioniert es!

Danke an Euch

Liebe Grüße

Susi


 

Beiträge aus den Excel-Beispielen zum Thema "Matrix Formel mit Textfeldern"