Microsoft Excel

Herbers Excel/VBA-Archiv

Formel als Text in Variable schreiben | Herbers Excel-Forum


Betrifft: Formel als Text in Variable schreiben von: Frank Schmalacker
Geschrieben am: 27.11.2009 14:41:18

Hallo zusammen,
in Zelle A1 habe ich eine einfache Formelverknüpfung in eine andere Datei. Sie sieht so aus:

='\\dfs\es-groups\cor\uhh\blabla\01_Forecast\2009\12_09\[datei.xls]2009'!A1

besteht die Möglichkeit die gesamte Formel (nicht das Ergebnis der Formel) in eine Textvariable zu schreiben und in Zelle A2 als Text ausgeben zu lassen?

Vielen Dank

  

Betrifft: Formel als Text mit Zelle.Zuordnen von: Matthias5
Geschrieben am: 27.11.2009 14:51:54

Hallo Frank,

angenommen die Formel steht in A1, der Text soll in B1 erscheinen:
- Markiere B1
- Lege über "Einfügen->Namen->definieren" einen Namen an, z.B. "Formel", und trage bei "bezieht sich auf" ein: =ZELLE.ZUORDNEN(41;A1)"
- Schreibe dann in B1: =Formel

Gruß,
Matthias


  

Betrifft: falscher Typ! von: Rudi Maintaire
Geschrieben am: 27.11.2009 15:00:30

Hallo,
41 Die in der aktiven Zelle stehende Formel, ohne diese zu übersetzen (hilfreich für internationale Makrovorlagen).
6 Die in Bezug stehende Formel als Zeichenfolge entweder in der A1- oder in der Z1S1-Schreibweise


Gruß
Rudi


  

Betrifft: OT : Unverschämte Aussage... ;-) von: NoNet
Geschrieben am: 27.11.2009 15:05:49

Hey Rudi,

so "falsch" ist der Typ (Matthias) nun auch wieder nicht ;-)

In früheren BASIC-Varianten (z.B. QuickBasic, ca. 1990) erschien dann immer die Meldung "Illegal type or character !"
Das habe ich jedoch nicht persönlich genommen, denn ein "Illegaler Typ" war ich nicht und SOOOO mies war mein Charakter (damals ;-) auch wieder nicht.

Gruß, NoNet


  

Betrifft: AW: OT : Unverschämte Aussage... ;-) von: Rudi Maintaire
Geschrieben am: 27.11.2009 16:03:52

Hallo,
ein illegaler Typ bin ich auch nicht. Eher unverträglich ;-)

Die Fehlermeldung kenn ich noch vom C64.

Gruß
Rudi


  

Betrifft: Der Unterschied ist mir nicht klar von: Matthias5
Geschrieben am: 27.11.2009 15:10:18

Hallo Rudi,

ich habe die Hilfedatei zu XL4-Makrofunktionen schon lange nicht mehr auf dem Rechner. Der Unterschied ist mir nicht ganz klar, kannst du mir die unterschiedliche Auswirkung noch mal erläutern?
Hier wird in beiden Fällen nichts übersetzt, kopierbar (unabhängig von aktiver Zelle) sind auch beide:


Tabelle2

 CDE
5  Formel=ZELLE.ZUORDNEN(41;Tabelle2!C6)
6  Formel2=ZELLE.ZUORDNEN(6;Tabelle2!B7)
7     
80=SUMMEWENN(A1:A6;"Gesamt*";C1:C6)=SUMMEWENN(A1:A6;"Gesamt*";C1:C6)
93=A4=A4

verwendete Formeln
Zelle Formel
C8 =SUMMEWENN(A1:A6;"Gesamt*";C1:C6)
D8 =Formel
E8 =Formel2
C9 =A4
D9 =Formel
E9 =Formel2

Tabellendarstellung in Foren Version 4.8

Gruß,
Matthias


  

Betrifft: HLP : Ich brauche eine Sicherheitskopie von: NoNet
Geschrieben am: 27.11.2009 15:29:31

Hallo Matthias,

kannst Du mir einen Tipp geben, wo ich eine "Sicherheitskopie" meiner XL4Macro-Helpdatei aufbewahren kann ;-)

Vielleicht hast Du ja noch ein paar KB auf Deiner Platte Platz ?

http://www.excelei.de/downloads/dateien/XLMACR8_deutsch.zip

Gruß, NoNet


  

Betrifft: Ich mach das mal für dich! ;-)) Dank dir! von: Matthias5
Geschrieben am: 27.11.2009 15:35:26




  

Betrifft: Der Unterschied ist mir aber immer noch unklar! oT von: Matthias5
Geschrieben am: 27.11.2009 15:37:32




  

Betrifft: AW: Formel als Text in Variable schreiben von: Rudi Maintaire
Geschrieben am: 27.11.2009 14:57:36

Hallo,
wozu eine Variable?
Range("A2")="'" &Range("A1").formulalocal

Alternative: definiere einen Namen
Name: Formel
Bezug: =ZELLE.ZUORDNEN(6;INDIREKT("Z(-1)S";0+JETZT()*0))
In A2 schreibst du =Formel

Gruß
Rudi


  

Betrifft: Danke an alle! von: Frank Schmalacker
Geschrieben am: 27.11.2009 15:00:33

-


Beiträge aus den Excel-Beispielen zum Thema "Formel als Text in Variable schreiben"