Microsoft Excel

Herbers Excel/VBA-Archiv

Text aus versch. Zellen einfügen, wenn

Betrifft: Text aus versch. Zellen einfügen, wenn von: Felix Bartelt
Geschrieben am: 14.11.2014 00:57:10

Ich möchte gerne alle Namen aus Spalte A + Vornamen aus Spalte B in Zelle A45 einfügen, wenn der Wert in Spalte C größer 0 ist und in Spalte D "ok" steht.
Wie geht das?

In A45 soll am Ende also eine Liste von Namen plus Vornamen erscheinen, die einen Wert von über 0 in C und "ok" in D haben.

  

Betrifft: AW: Text aus versch. Zellen einfügen, wenn von: Hajo_Zi
Geschrieben am: 14.11.2014 06:56:48

interpretiere ich das richtig Du möchtest in A45 max. 1.048.576 Vornamen und Nachnamen haben?

GrußformelHomepage


  

Betrifft: AW: Text aus versch. Zellen einfügen, wenn von: Felix Bartelt
Geschrieben am: 14.11.2014 07:24:12

Nee, in A45 können maximal die 44 Vornamen und Nachnamen aus den 44 Zeilen darüber stehen. Das ist zwar immer noch eine Zelle mit vielen Namen, aber tatsächlich gewollt.


  

Betrifft: AW: Text aus versch. Zellen einfügen, wenn von: {Boris}
Geschrieben am: 14.11.2014 08:49:53

Hi Felix,

Option Explicit

Sub til()
Dim strAllNames As String
Dim C As Range
For Each C In Range("A2:A44") 'Hier stehen die Nachnamen
    If C <> "" And C.Offset(0, 2) > 0 And C.Offset(0, 3) = "ok" Then
        strAllNames = strAllNames & C & ", " & C.Offset(0, 1) & vbLf
    End If
Next C
Range("A45") = Left(strAllNames, Len(strAllNames) - 1)
End Sub
VG, Boris


  

Betrifft: AW: Text aus versch. Zellen einfügen, wenn von: Felix Bartelt
Geschrieben am: 14.11.2014 08:51:53

Super. Vielen Dank!


  

Betrifft: AW: Text aus versch. Zellen einfügen, wenn von: Felix Bartelt
Geschrieben am: 14.11.2014 08:55:10

Gibt es da auch eine Lösung ohne Makro. Irgendetwas in Richtung: Wenn die Werte im Bereich, füge alle Namen aus...ein?


  

Betrifft: Elemente eines Array.... von: {Boris}
Geschrieben am: 14.11.2014 09:01:28

Hi Felix,

...lassen sich per Formel leider nicht verketten.
Und eine Abfrage nach dem Motto

=WENN(UND(A2<>"";C2>0;D2="ok");A2&", "&B2;"")&WENN(UND(A3<>"";C3>0;D3="ok"); A3&", "&B3;"")&WENN(UND(A4<>""....))

willst Du nicht wirklich formulieren ;-)

Alternativ kann man das auch mit einer UDF (=eigene Funktion) erledigen - ist aber eben auch VBA.

VG, Boris


  

Betrifft: AW: Elemente eines Array.... von: Felix Bartelt
Geschrieben am: 14.11.2014 09:29:16

Ok, danke. Wird auch ohne gehen.


 

Beiträge aus den Excel-Beispielen zum Thema "Text aus versch. Zellen einfügen, wenn"