Microsoft Excel

Herbers Excel/VBA-Archiv

Text aus einer Zeile in einer anderen Suchen

Betrifft: Text aus einer Zeile in einer anderen Suchen von: Resi
Geschrieben am: 19.11.2014 14:46:06

Hallo :)

ich habe eine Tabelle mit rund 2.500 Wörtern und eine andere mit rund 50.000 Sätzen. Nun muss ich wissen, wie oft welches Wort in den Sätzen vorkommt.

Hierfür habe ich folgende Formel verwendet:
=SUMMENPRODUKT(ISTZAHL(SUCHEN(A1; " "&Spalten in anderer Tabelle&" "))*1)

Habe auchnoch eine alternative Formel mit
=ANZAHL(SUCHEN(A1;" "&'Spalten in anderer Tabelle&" "))

beides funktioniert einwandfrei. Das Ergebnis gibt die Anzahl aller Wörter aus, in denen mein Wort aus Zelle A1 vorkommt.

Beispiel: Ich suche "aber" und es gibt die Wörter "aber." und "#aber" und "Laber"
Also ist mein Ergebnis hier: 3

Ich will es jetzt aber schaffen, dass wirklich nur das Wort "aber" gefunden wird. Also alle formen von aber (#aber aber! .aber aber. aber, ...) und "Laber" nicht gezählt wird.

Gibt es einen Platzhalter für Satzzeichen, der keine Buchstaben miteinbezieht?

Sodass ich die Formel so aufbauen könne: =SUMMENPRODUKT(ISTZAHL(SUCHEN("Platzhalter"&A1&"Platzhalter"; " "&Spalten in anderer Tabelle&" "))*1)

Ich kenne mich mit VBA leider garnicht aus und hoffe, dass dieses Problem einfach zu lösen ist. Bin aber offen, alles zu lernen.

Vielen Dank für die Hilfe!

  

Betrifft: AW: Text aus einer Zeile in einer anderen Suchen von: UweD
Geschrieben am: 19.11.2014 14:51:03

Hallo

Reicht es nicht, nach " "& A1 &" " zu suchen??

Also immer ein Leerzeichen davor und dahinter.


LG UweD


  

Betrifft: AW: Text aus einer Zeile in einer anderen Suchen von: Resi
Geschrieben am: 19.11.2014 16:14:26

Hallo UweD, danke für deine Antwort.

Leider reicht dies nicht, da dann alle Wörter mit einem # davor oder einem . oder ! danach nicht erkannt werden.

Ich habe schon sämtliche Wege ausprobiert aber kein Weg ist zu 100% korrekt. Deswegen wäre der Platzhalter ideal.


  

Betrifft: AW: Text aus einer Zeile in einer anderen Suchen von: Resi
Geschrieben am: 19.11.2014 16:18:23

Ich sehe gerade ich habe mich unverständlich ausgedrückt:

Ich möchte das "#aber" und "aber." und "aber!" und ".aber" erkannt werden.

Nur "Laber" soll nicht erkannt werden.


  

Betrifft: AW: Text aus einer Zeile in einer anderen Suchen von: Claus
Geschrieben am: 19.11.2014 19:58:34

Hallo Resi,

also falls es eine einmalige oder seltene Geschichte ist, du es also nicht ständig wieder benötigen würdest, schlage ich folgende Vorgehensweise vor:

Ersetze (Strg h) die Zeichen . und , etc. jeweils durch eine Leerstelle. Dann müsste die Formel mit " " vor und nach dem Suchbegriff funktionieren.

Liebe Grüße
Claus


 

Beiträge aus den Excel-Beispielen zum Thema "Text aus einer Zeile in einer anderen Suchen"