Das Archiv des Excel-Forums

zellenauswahl nach Textsuche

Bild

Betrifft: zellenauswahl nach Textsuche
von: Heiko

Geschrieben am: 24.09.2003 12:48:14

Hallo,
ich habe folgendes Problem: ich möchte den Inhalt einer Zelle ausgeben, nach Suche zweier Werte.
Beispiel: der Wert 80 und 105 sind in zwei verschiedenen Zellen vorhanden.
Die Ergebniszelle soll dann "DD80/105/115" ausgeben.
Meine Tabelle sieht wie folgt aus:

DD/DI
DD70/85
DD70/95,105
DD70/115,125
DD80/95
DD80/105,115
DD80/125,140

Freue mich über Antwort
Danke Heiko
Bild


Betrifft: AW: zellenauswahl nach Textsuche
von: Panicman
Geschrieben am: 24.09.2003 13:25:03

Hallo Heiko,

Lösung mit Hilfsspalte (im Beispiel SpalteB)


Download des Tabellenkonverters                 Formeln in den Zellen als QuickNotiz
Von Panicman
Bild
A B C
1 Werte 80 105
2     DD80/105,115
3      
4 DD/DI 0  
5 DD70/85 0  
6 DD70/95,105 0  
7 DD70/115,125 0  
8 DD80/95 0  
9 DD80/105,115 2  
10 DD80/125,140 0  


Formel: B4 =WENN(ISTFEHLER(SUCHEN("*"&$B$1&"*";A4)+SUCHEN("*"&$C$1&"*";A4));"";SUCHEN("*"&$B$1&"*";A4)+SUCHEN("*"&$C$1&"*";A4)) und runterkopieren
Formel: C2 =WENN(ISTFEHLER(INDEX(A4:A10;VERGLEICH(2;B4:B10;0)));"Kombination nicht vorhanden";INDEX(A4:A10;VERGLEICH(2;B4:B10;0)))

Gruß
Holger


Bild


Betrifft: AW: zellenauswahl nach Textsuche
von: Heiko
Geschrieben am: 24.09.2003 13:57:24

vielen dank.

hat perfekt geklappt!hat mir sehr geholfen.

gruß
heiko


Bild


Betrifft: Bitteschön, hab gern geholfen o.T.
von: Panicman
Geschrieben am: 24.09.2003 14:41:53




Bild


Betrifft: AW: zellenauswahl nach Textsuche
von: Karl-Otto Reimann
Geschrieben am: 24.09.2003 13:27:50

Hallo Heiko
Schau unter Droene 23.09. 16:25 nach
Glück Auf
K.O.


 Bild