Microsoft Excel

Herbers Excel/VBA-Archiv

Anhand eines Wertes Zelle finden | Herbers Excel-Forum


Betrifft: Anhand eines Wertes Zelle finden von: Ronald
Geschrieben am: 27.01.2010 09:16:55

Hallo Excel-Kracks

Mein Problem ist simpel und dennoch scheitere ich daran.
Via VBA suche ich in Spalte A bestimmte Werte. Anhand des jeweils gefundenen Wertes soll mir die Zellennummer zurückgegeben werden.

Beispiel:
Ich suche den Wert "Andy" in Spalte A.
Ich bekomme den Wert A23 zurück.
Davon brauche ich die Zahl 23

Weiss jemand einen Tipp?

Danke und Gruss
Ron

  

Betrifft: Fundzeile von: Rudi Maintaire
Geschrieben am: 27.01.2010 09:22:51

Hallo,
du solltest dich mal dazu äußern, wie du suchst.
Eine Möglichkeit:

Sub tt()
Dim lngZeile As Long
lngZeile = Application.Match("Andy", Columns(1), 0)
End Sub

Gruß
Rudi


  

Betrifft: AW: Fundzeile von: Ronald
Geschrieben am: 27.01.2010 10:42:47

Hallo Rudi

Danke für deine Hilfe.
Ich habe "Wert in Zelle" gesucht und auch vieles gefunden. Das Gefundene war aber nur im Zusammenhang mit noch anderen Problemen.

Deine Lösung ist Easy und Kurz.

Noch eine Frage:
Wie VBA möchte ich in eine Zelle folgendes schreiben;

=SUMME(D6:D48)

Wenn ich dies aufzeichne wir folgendes vorgeschlagen;
ActiveCell.FormulaR1C1 = "=SUM(R[-1]C[-7]:R[41]C[-7])
Gibt es da auch eine bessere Lösung?

Noch einmal Danke für deine Hilfe
Ron


  

Betrifft: AW: Fundzeile von: Beverly
Geschrieben am: 27.01.2010 10:49:29

Hi Ron,

ActiveCell.FormulaLocal = "=SUMME(D6:D48)"


GrußformelBeverly's Excel - Inn


  

Betrifft: Formel in Zelle von: Rudi Maintaire
Geschrieben am: 27.01.2010 10:49:33

Hallo,
ActiveCell.FormulaLocal="=Summe(D6:D48)"
Aber ob das besser ist? Flexibler ist R1C1.

Gruß
Rudi


  

Betrifft: AW: Formel in Zelle von: Ronald
Geschrieben am: 27.01.2010 11:05:49

Hallo Ruedi

Ich glaube mein Wunsch "explodiert".
Mit deiner Hilfe habe ich nun die Zellennummer gefunden in der ein bestimmter Text steht.

Damit möchte ich prüfen ob einen bestimmten Bereich erweitert oder verkleinert wurde.
Mit dem Resultat muss ich in einer Zelle einen "Befehl" anpassen. Dieser "Befehl" lautet z.B. =Summe(D6:D48)

Jetzt habe ich versucht diesen Befehl "anzupassen" und hier happert es.
ActiveCell.FormulaLocal = "=SUMME(D6:D48)"

Wie kann ich mögliche Variablen einfliesen lassen?
Dabei meine ich die Werte D6: und D48 die statt diesen Werten mit Variablenwerte ansprechen

Geht das?
Gruss und Danke
Ron


  

Betrifft: AW: Formel in Zelle von: Rudi Maintaire
Geschrieben am: 27.01.2010 13:02:39

Hallo,
ActiveCell.FormulaLocal = "=SUMME(" &Var1 &":" &Var2 &")"

Gruß
Rudi ohne e


  

Betrifft: AW: Formel in Zelle von: Ronald
Geschrieben am: 27.01.2010 13:15:39

Hallo Rudi

Entschuldige das "e".

Danke für deine Hilfe. Damit konnte ich mein Problem lösen.

Jetzt ist mein Wunsch zur vollen Zufriedenheit erfüllt.
Excel-Krack's sei Dank.

Gruss aus der Schweiz
Ron


Beiträge aus den Excel-Beispielen zum Thema "Anhand eines Wertes Zelle finden"