Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Doppelte Einträge in Formel nicht berücksichtigen

Doppelte Einträge in Formel nicht berücksichtigen
20.05.2009 10:30:17
Claudia
Hallo zusammen,
in Spalte A (ab Zeile 2) befinden sich Kundennummern - viele davon mehrfach.
Kann mir jemand mit einer Formel helfen, dass jede Kundennummer nur einmal gezählt wird, sprich doppelte Einträge sollen nicht berücksichtigt werden.
Beispiel
1234
5423
1234
Das wären also 2 Einträge, da 1234 mehrfach vorkommt.
Vielen Dank!
VG
Claudia

8
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Doppelte Einträge in Formel nicht berücksichtigen
20.05.2009 11:09:47
Claudia
Hallo David,
geht das auch einfacher? Ich habe 87.000 Datensätzen. Wenn ich das richtig verstanden habe, dann soll ich die Formeln 87.000 mal runterkopieren?
AW: Doppelte Einträge in Formel nicht berücksichtigen
20.05.2009 11:11:46
Hajo_Zi
Hallo Claudia,
wie schreibst Du 87.000 Datensätze in eine Tabelle die nur 65.536 Zeilen hat?
Ich gehe mal davon aus nach Deinem Beispiel, jeder Datensatz steht in einer Zeile.

Anzeige
AW: Doppelte Einträge in Formel nicht berücksichtigen
20.05.2009 11:14:50
David
geht das auch einfacher?
Sicherlich, wende dich bitte vertrauensvoll an die zuständige Programmierabteilung bei Microsoft.
Sorry, aber ICH habe Excel nicht gemacht.
Gruß
David
AW: Doppelte Einträge in Formel nicht berücksichtigen
20.05.2009 11:41:09
Claudia
Das war auch nicht böse gemeint. Aber es macht mir Angst. :-)
Hajo: Du bist ein Aufpasser: 65.000 sind in dem einen Blatt und der Rest im anderen Blatt. :-)
Sonst keine Möglichkeit?
Spezialfilter, ohne Duplikate
20.05.2009 15:07:15
Jan
oT
AW: Spezialfilter, ohne Duplikate
20.05.2009 15:19:30
David
Hallo Jan,
die so erzeugte Liste ist dann aber nicht dynamisch und der Schritt muss immer wieder ausgeführt werden.
Ansonsten ist dagegen nix einzuwenden.
Gruß
David
Wenn-Formel?
20.05.2009 16:01:50
Claudia
Hallo,
habe jetzt über eine Hilfsspalte die Lösung gefunden.
In B3 kommt rein =WENN(A2=A3;0;1) und das kopiere ich runter. Ging schnell.
Viele Grüße und danke für die Vorschläge!
Claudia
Anzeige

310 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige