Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Spalte A auf Textstrings in Spalte B abgleichen

Spalte A auf Textstrings in Spalte B abgleichen
07.05.2013 17:39:13
Chris
Hallo zusammen
grundsätzlich möchte ich zwei Spalten "gegeneinander" abgleichen
=wenn("textbestandteil aus spalte B" in Spalte A vorkommt dann "ja";"nein")
Ich habe in Spalte A eine Liste mit ca. 2000 verschiedenen Firmennamen, diese können jedoch von Fall zu Fall leicht divergieren:
- die Rechtsbezeichnung einmal mit Ltd Angabe, dann wieder mit AG
- oder aber XYZ Division India (anstelle von XYZ Ltd)
entsprechend habe ich in einer zweiten Spalte B (ca. 50 Werte) eineindeutige Werte definiert z.B. XYZ, ABC, EFG, HIJ etc.
Nun möchte ich prüfen, in welcher dieser 500 Firmennamen einer dieser eineindeutigen Werte (ca. 50 Textstrings) vorkommt. Falls es eine Übereinstimmung gibt, soll mir dies in einer dritten Spalte mit "ja" angegeben werden, ansonsten mit "nein".
Ich bedanke mich im Voraus für Eure Bemühungen.
Beste Grüsse,
Chris

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
=Zählenwenn() mit Platzhalter
07.05.2013 17:59:23
ransi
HAllo Chris
Versuch mal so:
Tabelle1

 ABC
1DNRWEAJa
2MZSOTBNein
3YMFdOCJa
4ETSAA  
5DFUEHC  
6DDYZL  
7LVEPE  
8FIKAA  
9GXATY  
10   

Formeln der Tabelle
ZelleFormel
C1=WENN(ZÄHLENWENN(A:A;"*"&B1&"*"); "Ja";"Nein")
C2=WENN(ZÄHLENWENN(A:A;"*"&B2&"*"); "Ja";"Nein")
C3=WENN(ZÄHLENWENN(A:A;"*"&B3&"*"); "Ja";"Nein")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
ransi

Anzeige
AW: =Zählenwenn() mit Platzhalter
07.05.2013 18:14:58
ransi
HAllo
Vrgiss meinen letzten Post. ICh hatte die Frage wohl falsch verstanden.
Versuch mal so:
Tabelle1

 C
1Nein

Formeln der Tabelle
ZelleFormel
C1=WENN(SUMMENPRODUKT(ZÄHLENWENN(A1;"*"&$B$1:$B$3&"*")); "Ja";"Nein")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
ransi

Anzeige
AW: =Zählenwenn() mit Platzhalter
07.05.2013 18:15:37
ransi
Tabelle1

 ABC
1DNRWEANein
2MZSOTBNein
3YMFdOCNein
4ETSAA Ja
5DFUEHC Ja
6DDYZL Nein
7LVEPE Nein
8FIKAA Ja
9GXATY Ja
10   

Formeln der Tabelle
ZelleFormel
C1=WENN(SUMMENPRODUKT(ZÄHLENWENN(A1;"*"&$B$1:$B$3&"*")); "Ja";"Nein")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Anzeige
AW: =Zählenwenn() mit Platzhalter
12.05.2013 13:22:27
Ryf
Hallo Ransi
Sorry für meine späte Antwort. Dein Vorschlag ist genau, wonach ich gesucht habe. Besten Dank und einen schönen Sonntag.
Grüsse
Chris

AW: Spalte A auf Textstrings in Spalte B abgleichen
07.05.2013 18:05:12
Christian
Hallo Chris,
ein Ansatz: (Bereiche anpassen)
 ABC
1Meier GmbHMüllerja
2Meier Ltd.Meierja
3Müller KGFranzja
4Müller GmbH ja
5Meier GbR ja
6Karl Gmbh nein
7Franz GmbH ja
8Schneider KG nein

Formeln der Tabelle
ZelleFormel
C1{=WENN(SUMME(WENN(ISTZAHL(FINDEN($B$1:$B$3;A1)); 1;0)); "ja";"nein")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
MfG Christian
Anzeige

328 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige