Variierende Zellen einer Zeile - Formelanwendung

Bild

Betrifft: Variierende Zellen einer Zeile - Formelanwendung
von: Milich
Geschrieben am: 22.08.2015 19:52:24

Hallo zusammen,
ich zerbreche mir schon den ganzen Tag meinen Excel Anfänger Kopf und weiß einfach nicht weiter. Vielleicht weiß ein schlauer Kopf Rat:
Ziel ist, Werte verschiedener Zellen innerhalb einer Zeile ändern sich täglich, wobei sich andere Zellen innerhalb der Zeile verändern, oder ihren Wert behalten sollen.
Folgendes Szenario:
Tag 1:
A1 = 100
B1 = 100
C1 variiert und ist entweder größer, kleiner, oder gleich 100 in B1
D1 = 15% von A1
E1 variiert: wenn C1 größer B1 dann ist E1 = 15% von C1
wenn C1 kleiner B1 dann ist E1 = D1
wenn C1 gleich B1 dann ist E1 = D1
Tag 2:
A1 = 100
In B1 wird der Wert von C1 umgetragen
C1 variiert wieder und ist größer, kleiner, oder gleich dem Wert von B1
D1 bleibt 15% von A1
E1 soll nun intelligent variieren: wenn C1 größer B1 dann ist E1 = 15% von C1, erhöht sich also
wenn C1 kleiner B1 hält E1 seinen Wert!
wenn C1 gleich B1 hält E1 seinen Wert!
In den darauffolgenden Tagen läuft es so weiter. Immer wird der Wert von C1 nach B1 umgetragen und in C1 ein neuer Wert eingetragen, der, wenn er steigt, den Wert in E1 erhöht. Ist C1 geringer oder gleich B1, soll der Wert in E1 erhalten bleiben.
Kann man so eine Variation überhaupt in einer Zeile abbilden?
Herzlichen Dank für Mühe und Hilfe!!
Roland

Bild

Betrifft: AW: so wie die bisher geschrieben hast ...
von: ... neopa C
Geschrieben am: 23.08.2015 08:13:15
Hallo Roland,
... und ich wie ich Deine Angaben deute, so:

 ABCDE
11001001201518

Formeln der Tabelle
ZelleFormel
D1=15%*A1
E1=WENN(C1>B1;15%*C1;D1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: AW: so wie die bisher geschrieben hast ...
von: Milich
Geschrieben am: 23.08.2015 14:25:41
Hallo Werner,
großen Dank für die Mühe und die schnelle Antwort!
Für den ersten Tag ist die Tabelle perfekt. Mit viel Probieren hatte ich dies geschafft. Mein großes Problem entsteht, wenn ich die Werte in den Zeilen A und B verändere:
120 soll von Spalte C in Spalte B umgetrgaen werden können. Dabei soll sich die 18 in Spalte E jedoch nur dann verändern, wenn im Folgenden ein größerer Wert als 120 in Spalte C eingetragen wird. Bleibt der Wert in Spalte C gleich oder gar kleiner dem in Spalte B, bleibt die 18. Ist er jedoch größer, würde er sich verändern und wiederum 15% von Spalte C abbilden.
Ich weiß halt nicht genau, ob dies irgendwie mit einer Formel abzubilden ist, oder man mehr / andere Spalten benötigt.
Herzlichen Dank!!
Roland

Bild

Betrifft: AW: so wie Du nun ergänzt hast ...
von: ... neopa C
Geschrieben am: 24.08.2015 10:53:15
Hallo Roland,
... müsste die Formel in E1 nur um ein Gleichheitszeichen ergänzt werden und zwar so:

 ABCDEF
11001201201518 

Formeln der Tabelle
ZelleFormel
D1=15%*A1
E1=WENN(C1>=B1;15%*C1;D1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: AW: so wie Du nun ergänzt hast ...
von: Milich
Geschrieben am: 24.08.2015 13:39:10
Hallo Werner,
hat Gleichzeichen hilft sehr!! Ich wusste nicht, dass man mehrere Vorzeichen setzten kann.
Diese Formel ist perfekt, solange C größer als B bleibt! Wenn aber nun der Wert in B wieder sinkt, wäre es dann noch zu schatten, den Wert in E NICHT kleiner werden zu lassen? Er soll einfach bleiben.
Diese Situation suchen ich:
Tag 1: C größer D somit steigt D oder C=D somit bleibt E
Tag 2: Wert C wird in Wert B gesetzt
In C wir ein Wert größer B gesetzt somit steigt E
Tag 3: Wert C wird wieder nach B gesetzt
In C wird nun ein Wert kleiner B gesetzt somit bleibt E gleich
Tag 4: Wert C wird nach B gesetzt
Nun soll passieren, dass E seinen Wert NICHT verändert, sondern den Wert vom Vortag hält
Das könnte ich mir jetzt schwierig vorstellen, den der Berechnungswert ist ja nicht mehr da weil er ersetzt wurde. Vielleicht braucht man jetzt auch mehr Zeilen?
Am Ende dreht sich die Ganze Sache um Aktienkurse und einen mitziehenden Stop. Steigt der Kurs, zieht der Stop um beispielsweise 15% mit. Fällt der Kurs im Vergleich zum Vortag, bleibt der Vortages Stop erhalten und fällt nicht mit. Er steigt erst wieder dann, wenn der Kurs einen höheren Wert als der höchste Stop erreicht hat.
Vielleicht hast du noch eine schlaue Idee?
Ganz großen Dank für die tolle Hilfe!
Roland

Bild

Betrifft: AW: hab ich es mir doch fast gedacht ...
von: ... neopa C
Geschrieben am: 24.08.2015 13:50:25
Hallo Roland,
... so wie Du es jetzt beschreibst, geht es standardmäßig nicht auszuwerten (bzw. nur mit VBA oder mit Einstellungen zu denen ich nicht rate).
Abhilfe ist jedoch möglich, wenn Du Deine Daten und Auswertung nicht auf eine Zeile beschränkst, sondern je Tag die Daten in die jeweils erste Zeile unterhalb der letzten Datenzeile erfasst und dort auswertest mit Bezug und Berücksichtigung auf das vorherige Tagesergebnis (Datenzeile)
Gruß Werner
.. , - ...

Bild

Betrifft: AW: hab ich es mir doch fast gedacht ...
von: Milich
Geschrieben am: 24.08.2015 14:08:23
Hallo Werner,
an so etwas habe ich auch gedacht. Unwahrscheinlich, dass es in einer Zeile klappen hätte können.
Ich werde mal ein bisschen versuchen zu basteln. Ich habe ja jetzt ganz viele Anregungen und Tipps bekommen. Bestimmt melde ich mich aber wieder :)
Herzlichen Dank!
Roland

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Variierende Zellen einer Zeile - Formelanwendung"