Microsoft Excel

Herbers Excel/VBA-Archiv

VBA für Formel in Zelle schreiben und ausfüllen

Betrifft: VBA für Formel in Zelle schreiben und ausfüllen von: urs
Geschrieben am: 03.10.2014 13:26:11

Hallo zusammen
Ich habe mit dem Makrorekorder versucht diese Formel
=WENN(A2grösser0;VERKETTEN(C2;D2);"") in Zelle K2 zu schreiben und von dort bis zur letzten Zeile mit A grösser 0 zu kopieren.
Die Aufzeichnung hat
ActiveCell.FormulaR1C1 = "=IF(A2grösser0,CONTENATE(C2,D2),"""")" ergeben und dann Fehlermeldung.

Ich werde nicht schlau daraus. Springt einem von Euch der Fehler gerade ins Auge?
Danke für jede Hilfe. Gruss Urs

  

Betrifft: VBA Formel in Zelle von: Crazy Tom
Geschrieben am: 03.10.2014 13:29:34

Hallo

das sollte dann so aussehen

ActiveCell.FormulaR1C1 = "=IF(RC[-10]>0,CONCATENATE(RC[-8],RC[-7]),"""")"

MfG Tom


  

Betrifft: AW: VBA Formel in Zelle mit direktem Bezug von: urs
Geschrieben am: 03.10.2014 14:24:13

Hallo Tom
vielen Dank für Deine schnelle Hilfe. Es hat geklappt. Darf ich noch eine Frage dazu anhängen?
Wie müsste ich die Syntax aufbauen, wenn ich die Zelle direkt ansprechen will und nicht über die relativen Bezüge? Geht das überhaupt oder bin ich auf dem Holzweg? Gruss Urs


  

Betrifft: AW: VBA Formel in Zelle mit direktem Bezug von: Hajo_Zi
Geschrieben am: 03.10.2014 16:33:27

ActiveCell.Formula = "=IF(A1>0,CONCATENATE(B8,C9),"""")"

Ich habe jetzt irgendwelche Zelle gewählt.

GrußformelHomepage


  

Betrifft: AW: VBA Formel in Zelle mit direktem Bezug von: urs
Geschrieben am: 03.10.2014 20:49:07

Hallo Hajo
Danke für die schnelle Hilfe. Ich hoffe den Rest bekomme ich zusammen. Gruss Urs


 

Beiträge aus den Excel-Beispielen zum Thema "VBA für Formel in Zelle schreiben und ausfüllen"