Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zellen mit Doppelwerten auswerten

Zellen mit Doppelwerten auswerten
Andreas
Hallo Excelfreunde!
Ich habe in Zelle A1 Text im folgenden Format stehen:
Text1 : Text2
und in Zelle B1 zum Beispiel folgendes:
1:2
Ich möchte gern, das in Zelle C1 der linke oder rechte Wert aus Zelle A1, abhängig vom linken oder rechten Wert aus Zelle B1 steht, also in diesem Beispiel sollte in C1 "Text2" stehen.
Ich glaube schon einen Lösungsansatz gefunden zu haben, komme aber damit nicht weiter:
=WENN($B1="";"";WENN(WERT(LINKS($B1))>WERT(RECHTS($B1));WERT(LINKS($A1));WERT(RECHTS($A1))))
Vieleicht kann mir Jemand helfen.
mfg, Andreas

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Zellen mit Doppelwerten auswerten
22.06.2010 19:15:03
BoskoBiati
Hallo,
probiers mal so (ungetestet):
=wenn(links(b1;suchen(":";b1)-1)*1>rechts(b1;länge(b1)-suchen(":";b1))*1;links(a1;suchen(":";a1)-1); rechts(a1;länge(a1)-suchen(":";a1))) 
Gruß
Bosko
AW: Zellen mit Doppelwerten auswerten
22.06.2010 19:24:11
Andreas
Hallo Bosko!
Danke für die schnelle Hilfe! Funktioniert super!
mfg, Andreas
Anzeige

351 Forumthreads zu ähnlichen Themen


Guten Morgen!
Ich hätte folgendes Problem: Ich erhalte automatisiert Exceltabellen, bei denen nicht alle Zellen einer Zeile gefüllt werden, wenn dort der Inhalt einer darüberliegenden Zeile stehen sollte. Zur Weiterverarbeitung muss ich aber diese Zellen mit den dazugehörigen Werten füllen....
Anzeige

hallo,
ich muß eine liste erstellen. die werte unten will ich nicht immer eingeben müssen, sondern nur dort wo ein wert stehen soll ein x machen. excel soll mir dann für jedes x den wert aus der zeile 2 der gleichen spalte eintragen. mache ich in eine zelle 2 x, dann muß der wert auch 2 mal...

Hallo,
kann ich den Inhalt einer Zelle im Windows Infobereich anzeigen lassen?
Ich habe eine VBA-Anwendung, die mir den Verarbeitungsstatus in einer Zelle anzeigt.
Weil die Verarbeitung sehr lange dauert möchte ich zwischendurch mit anderen Anwendungen arbeiten und unten rechts nebe...
Anzeige

Guten Morgen!
Ich habe z.B. in der Zelle A1 den Wert 5 stehen. Wird dieser Wert z.B. um die Zahl 3 verringert, dann soll der vorhandene Wert in der Zelle B1 um die Zahl 3 erhöht werden. Wie würde hier bitte eine Formellösung dafür lauten?
Danke
Josef

Hallo zusammen.
Ich habe in einer Zelle einen etwas längeren Text (mit Zahlen und Buchstaben). Ich würde jetzt gerne hieraus den Wert rausfiltern (in separate Spalte), der neben der Buchstabenkombination "AT" steht.
Hört sich einfach an. Da gibt es aber noch einige Sonderfälle.
Ich...

Hallo,
ich lauf gerade wieder mal mit einem Brett vorm Kopf rum und hoffe, mir kann einer hier helfen.
Ich habe in einer Zelle mehrere Werte stehen, die jeweils durch Semikolon getrennt sind (bis zu 15).
Wie kann ich per VBA eine Schleife erstellen, dass solange nach einem Wert gesu...
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige