Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn Wert dann Nachbarzeile ausgeben

Betrifft: Wenn Wert dann Nachbarzeile ausgeben von: Torsten
Geschrieben am: 05.04.2014 12:43:58

Hallo,

ich habe eine Excel Liste mit 3 Spalten

Spalte A Artikelnummern
Spalte B Bildername alt
Spalte C Bildername neu

Wenn nun in Spalte B (Bildername alt) ein Wert steht, dann soll in Spalte C (Bildername neu) der Wert A (Artikelnummer) ausgegeben werden. Zwischen den Zeilen in Spalte B sind aber auch viele Leerzeilen, diese sollten dann nicht berücksichtigt werden. Dazu wäre es äusserst praktisch, wenn die ausgegebenen Werte in Spalte C gleich die Endung .jpg zugefügt bekommen.

https://www.herber.de/bbs/user/90004.xlsx

Gruß Torsten

  

Betrifft: AW: Wenn Wert dann Nachbarzeile ausgeben von: Crazy Tom
Geschrieben am: 05.04.2014 12:55:27

Hallo Torsten

vielleicht so als Formel

=WENN(B2<>"";A2&".jpg";"")

und so mit VBA

Sub test()
    Dim iZaehler As Long
    For iZaehler = 2 To Cells(Rows.Count, 2).End(xlUp).Row
        If Cells(iZaehler, 2).Value <> "" Then
            Cells(iZaehler, 3).Value = Cells(iZaehler, 1).Value & ".jpg"
        End If
    Next
End Sub
MfG Tom


  

Betrifft: AW: Wenn Wert dann Nachbarzeile ausgeben von: Torsten
Geschrieben am: 05.04.2014 13:18:07

Wow! Super, hat geklappt!

Vielen Dank Tom!


  

Betrifft: AW: Danke für die Rückmeldung, owT von: Crazy Tom
Geschrieben am: 05.04.2014 13:19:16




 

Beiträge aus den Excel-Beispielen zum Thema "Wenn Wert dann Nachbarzeile ausgeben"