Microsoft Excel

Herbers Excel/VBA-Archiv

Formel für nur Zahlen addieren?

Betrifft: Formel für nur Zahlen addieren? von: Tom
Geschrieben am: 11.08.2008 16:29:04

Hi,
ich schreib mir gerade ein kleines Kostenformular. Dazu schreib ich in Zeile 5 das Datum und in Zeile 6 den Betrag.

5: 6.7.2008
6: 300€

Gibt es jetzt eine Möglichkeit mit VBA oder lieber ohne, nur die Eurobeträge zu addieren ohne die Datums Zahlen? Also das € Zeichen kann rein muss aber nicht.

mfg Tom

  

Betrifft: AW: Formel für nur Zahlen addieren? von: Daniel
Geschrieben am: 11.08.2008 16:44:10

Hi

es ist eine alte Regel der EDV, daß in einer Spalte immer nur eine Wertart stehen sollte.
das Datum muss in Spalte A und der Betrag muss in Spalte B in der gleichen Zeile
dann kannst du problemlos aufsummieren und auch weitere Auswertungen machen (ausgegebene Summe pro tag usw)
(ein Datum ist auch nur eine Zahl, daher gibts keine Chance, das zu differenzieren)

anderen Falls könnte noch folgendes Helfen:
Variant 1
Das Datum nicht als Datumswert, sondern als Text-String eingeben (mit dem Hochkomma ' davor oder vorab schon als Text formatieren), denn Textwerte werden in der Summe nicht berücksichtigt.

Variante2:
über folgende Formel nur die geraden Zeilen aufsummieren: und die ungeraden ignorieren =SUMMENPRODUKT(B5:B15;REST(ZEILE(B5:B15)+1;2))

variante3:
die Summenformel entsprechend schreiben:
=Summe(A6;A8;A10;A12)

Gruß, Daniel


  

Betrifft: AW: Formel für nur Zahlen addieren? von: David
Geschrieben am: 11.08.2008 16:46:11

Ohne ein weiteres Kriterium ist das per Formel nicht möglich, da für Excel ein Datum genau so eine Zahl ist wie dein Betrag, alles eine Frage der Formatierung. Und Formatierungen lassen sich nur mit VBA auslesen.

Gruß

David


  

Betrifft: AW: Formel für nur Zahlen addieren? von: {Boris}
Geschrieben am: 11.08.2008 16:54:18

Hi Tom,

wenn Deine Beträge nicht zu groß sind und die Datümer nicht weit in der Vergangenheit liegen können:

=SUMMEWENN(A:A;"<39000")

39000 entspricht dabei dem 10.10.2006. Wenn die Beträge also immer kleiner als 39000 und die Datümer immer jünger sind, kannst Du das so machen.
Allerdings ist das nicht unbedingt elegant.

Grüße Boris


  

Betrifft: AW: Formel für nur Zahlen addieren? von: Bernd
Geschrieben am: 13.08.2008 08:48:23

Hallo, Tom!

Anbei mal eine Beispieldatei: https://www.herber.de/bbs/user/54561.xls

Wenn Dein Aufbau der Spalte konsequent ist und abwechselnd Datum - Betrag - Datum - Betrag - ... aufweist, sollten die Formeln funktionieren.

Achtung: Je nach dem ob der erste Betrag in einer geraden oder ungeraden Zeile steht, mußt Du die entsprechende Formel aus der Beispieldatei anwenden ... und natürlich auf Deinen Bereich anpassen.

Gruß Bernd


 

Beiträge aus den Excel-Beispielen zum Thema "Formel für nur Zahlen addieren?"