nur Zahlen in den Zellen addieren

Bild

Betrifft: nur Zahlen in den Zellen addieren
von: rieckmann
Geschrieben am: 24.08.2015 08:51:46

Hallo,
ich suche eine Formel die nur Zahlen aus mehrerer Zeilen addiert wo aber auch Text enthalten ist.
Beispiel in Spalte A:
1 Hefter
2 Akten
10 Binder
Nun soll die Anzahl alle Objekte gezählt werden
Ergebnis hier also 13
Wüsste da jemand eine Formel ?
Gruß
Fred

Bild

Betrifft: AW: nur Zahlen in den Zellen addieren
von: Dieter
Geschrieben am: 24.08.2015 09:01:38
Hi Fred,
das könnte Dir weiter helfen (im Internet gefunden): http://excelformeln.de/formeln.html?welcher=105
Gruß, Dieter

Bild

Betrifft: AW: nur Zahlen in den Zellen addieren
von: rieckmann
Geschrieben am: 24.08.2015 09:22:00
Hallo Dieter,
danke für die Info.
Klappt leider nicht weil ich vergessen hab im Beispiel anzugeben dass auch
in manchen Zellen nur Zahlen stehen.
Also so:
1 Ordner
5 Hefter
4
2 Blätter
6
3 Akten
usw.
Gruß
Fred

Bild

Betrifft: AW: Da kann ich nicht weiter helfen. owT.
von: Dieter
Geschrieben am: 24.08.2015 09:32:03


Bild

Betrifft: AW: Da kann ich nicht weiter helfen. owT.
von: rieckmann
Geschrieben am: 24.08.2015 09:36:35
O.K. Danke trotzdem
evt. weis ein anderer eine Lösung.
Gruß
Fred

Bild

Betrifft: AW: Dann mal so
von: hary
Geschrieben am: 24.08.2015 10:18:51
Moin



Tabelle1

 ABC
111 ordner 22
25 hefter  
34  
42 blaetter  
5   

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
C1{=SUMME(WENN(ISTZAHL(FINDEN(" ";A1:A4));LINKS(A1:A4;FINDEN(" ";A1:A4))*1))+SUMME(A1:A4)}$C$1 =SUM(IF(ISNUMBER(FIND(" ",RC[-2]:R[3]C[-2])),LEFT(RC[-2]:R[3]C[-2],FIND(" ",RC[-2]:R[3]C[-2]))*1))+SUM(RC[-2]:R[3]C[-2])
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!


http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary

Bild

Betrifft: AW: Prima Lösung
von: Dieter
Geschrieben am: 24.08.2015 10:26:33
Hallo Harry,
ich bin zwar nicht der ursächliche Fragesteller, aber Deine Lösung funktioniert und interessierte mich auch.
Gruß, Dieter
(Dieter(Drummer)

Bild

Betrifft: AW: OT. Dieter?????
von: hary
Geschrieben am: 24.08.2015 10:30:28
Moin Dieter
Hast du die Drumsticks an den Nagel gehaengt oder warum jetzt ohne "Drummer"?
gruss hary

Bild

Betrifft: AW: OT. Dieter?????
von: Dieter
Geschrieben am: 24.08.2015 10:37:12
Maoin, Hary,
nach 50 Jahren Drummer in versch. Bands (als Hobby), habe ich mich komplett von der Musik verabschiedet.
Wenn ich Lust zum Drumming habe, spiele ich noch auch meinem Drumset (Elektro).
Ich verkaufe auch alles von meinem Drumbereich.
Gruß, Dieter

Bild

Betrifft: AW: OT. Dieter?????
von: hary
Geschrieben am: 24.08.2015 10:51:08
Moin
Hast es dir verdient. Aber schreib (Ex-Drummer) Dieter gibt es wie Sand am Meer. LOL
gruss hary

Bild

Betrifft: kleiner Trick mit &" "
von: WF
Geschrieben am: 24.08.2015 10:35:35
Hi,
={SUMME(WENN(A1:A99<>"";LINKS(A1:A99;FINDEN(" ";A1:A99&" "))*1))}
Salut WF

Bild

Betrifft: AW: Danke WF, funktioniert prima. owT
von: Dieter
Geschrieben am: 24.08.2015 10:45:26


Bild

Betrifft: AW: kleiner Trick mit &" "
von: rieckmann
Geschrieben am: 24.08.2015 11:21:57
Hallo WF,
ich bekomme einen Wert Fehler bei
=SUMME(WENN(N:N<>"";LINKS(N:N;FINDEN(" ";N:N&" "))*1)) (Als Matrix Formel abgeschlossen)
Gruß
Fred

Bild

Betrifft: AW: kleiner Trick mit &" "
von: hary
Geschrieben am: 24.08.2015 11:26:49
Moin
Sind vor den Zahlen evtl. auch Leerzeichen?
gruss hary

Bild

Betrifft: AW: Dann mal so
von: rieckmann
Geschrieben am: 24.08.2015 11:27:16
Moin Hary,
mit deiner Formel komme ich nicht klar !
Wie und was muss ich mit "R1C1 für Add In" machen ?
Habe keine Erfahrung mit Add In
Gruß
Fred

Bild

Betrifft: AW:mit WF Formel
von: hary
Geschrieben am: 24.08.2015 11:39:51
Moin Fred
WF hat die bessere Loesung.
Mit dem Addin ist nur zum Anzeigen in Foren.
Teste mal so.



Tabelle1

 ABCDE
111 ordner mit Glättenohne Glätten11 ordner
2 5 heftervor der 5 ein Leerziechen21#WERT!5 hefter
33   3
42 blaetter   2 blaetter
5     

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
C2{=SUMME(WENN(A:A<>"";LINKS(GLÄTTEN(A:A);FINDEN(" ";A:A&" "))*1))}$C$2 =SUM(IF(C[-2]<>"",LEFT(TRIM(C[-2]),FIND(" ",C[-2]&" "))*1))
D2{=SUMME(WENN(A:A<>"";LINKS(A:A;FINDEN(" ";A:A&" "))*1))}$D$2 =SUM(IF(C[-3]<>"",LEFT(C[-3],FIND(" ",C[-3]&" "))*1))
E1:E4=GLÄTTEN(A1)  =TRIM(RC[-4])
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!


http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary

Bild

Betrifft: AW: AW:mit WF Formel
von: rieckmann
Geschrieben am: 24.08.2015 11:57:05
Hallo,
egal welche Formel ich nehme bekomme immer der WERT Fehler !
Die Spalte ist im Format "Standart" !
{=SUMME(WENN(ISTZAHL(FINDEN(" ";N:N));LINKS(N:N;FINDEN(" ";N:N))*1))+SUMME(N:N)}
Gruß
Fred

Bild

Betrifft: AW: AW:mit WF Formel
von: rieckmann
Geschrieben am: 24.08.2015 12:08:27
Hallo an alle,
kleine Fehler große Wirkung !
Der WERT Fehler kam weil in einer Zelle anstatt der 1 ein ! stand !!!!!!
Danke an alle. Nun klappt es wunderbar.
Gruß
Fred

Bild

Betrifft: AW: AW:mit WF Formel
von: rieckmann
Geschrieben am: 24.08.2015 12:24:41
Hallo an alle,
kleine Fehler große Wirkung !
Der WERT Fehler kam weil in einer Zelle anstatt der 1 ein ! stand !!!!!!
Danke an alle. Nun klappt es wunderbar.
Gruß
Fred

 Bild

Beiträge aus den Excel-Beispielen zum Thema "nur Zahlen in den Zellen addieren"