Microsoft Excel

Herbers Excel/VBA-Archiv

Zusammenzählen Wenn Summe | Herbers Excel-Forum


Betrifft: Zusammenzählen Wenn Summe von: Heinz H
Geschrieben am: 30.12.2009 16:25:24

Hallo Leute

Ich habe in G6:G35 einigemale die Formel =SUMME stehen.

Nun möchte ich in G36 die Gesamtsummen von =SUMME zusammenzählen.

Zb. In G8 =SUMME(G6:G7) , In G25 =SUMME(G14:G19) usw.

Nur die Zellen mit der Formel sind Variabel.

Hatte dazu jemand bitte eine Formel ?

Gruß
Heinz

  

Betrifft: mE nur mit VBA von: Matthias L
Geschrieben am: 30.12.2009 17:00:04

Hallo Heinz

Hab da mal ein Beispiel erstellt
https://www.herber.de/bbs/user/66891.xls

Neben den Einträgen in G6:G35 wird per vba ein "x" gesetzt,
wenn sich in der Zelle eine Formel befindet.
Es wird allerdings nicht auf "SummenFormel" geprüft, sondern nur ob eine Formel in der Zelle steht.
Aber evtl. hilft Dir das schon weiter.

Gruß Matthias


  

Betrifft: AW: Zusammenzählen Wenn Summe von: hary
Geschrieben am: 30.12.2009 17:01:54

hallo Heinz
bezieht sich das auf Deine alten Threads?
dann versuch mal:

=SUMMEWENN(A6:A35;"";G6:G35)

zaehlt die zellen in G6 bis G35 zusammen wo in SpalteA kein Datum steht.
Gruss hary


  

Betrifft: AW: An Hary & Matthias von: Heinz H
Geschrieben am: 30.12.2009 17:07:12

Hallo Hary & Matthias

Erstmals Danke für Eure Hilfestellung !!

Leider sind in G6:G36 lauter Formeln drinnen.

Siehe unten.
Gruß
Heinz

01.10.2002

 G
1016,00
111,50
122,50
133,50
144,50
155,50
1617,50

Formeln der Tabelle
ZelleFormel
G10=SUMME($G$6:$G$9)
G11=WENN(ISTFEHLER(VERGLEICH(A11;$W$64:$W$81;0)); WENN(A11="";"";INDIREKT("G"&WOCHENTAG(B11)+41)); "")
G12=WENN(ISTFEHLER(VERGLEICH(A12;$W$64:$W$81;0)); WENN(A12="";"";INDIREKT("G"&WOCHENTAG(B12)+41)); "")
G13=WENN(ISTFEHLER(VERGLEICH(A13;$W$64:$W$81;0)); WENN(A13="";"";INDIREKT("G"&WOCHENTAG(B13)+41)); "")
G14=WENN(ISTFEHLER(VERGLEICH(A14;$W$64:$W$81;0)); WENN(A14="";"";INDIREKT("G"&WOCHENTAG(B14)+41)); "")
G15=WENN(ISTFEHLER(VERGLEICH(A15;$W$64:$W$81;0)); WENN(A15="";"";INDIREKT("G"&WOCHENTAG(B15)+41)); "")
G16=SUMME($G$11:$G$15)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


  

Betrifft: AW: An Hary & Matthias von: hary
Geschrieben am: 30.12.2009 17:12:23

hallo Heinz
macht doch nix. siehe(Ausschnitt aus tabelle):

01.12.2009

 ABCDEFGHI
2624.12.2009Do             
2725.12.2009Fr             
28            7,50   
2928.12.2009Mo        1,50   
3029.12.2009Di        2,50   
3130.12.2009Mi        3,50   
3231.12.2009Do             
3330.12.2339          7,50   
34              56Hier Summe
35                 

verwendete Formeln
Zelle Formel
G26 =WENN(ISTFEHLER(VERGLEICH(A26;$W$64:$W$81;0));WENN(A26="";"";INDIREKT("E"&WOCHENTAG(B26)+41));"")
G27 =WENN(ISTFEHLER(VERGLEICH(A27;$W$64:$W$81;0));WENN(A27="";"";INDIREKT("E"&WOCHENTAG(B27)+41));"")
G28 =SUMME($G$23:$G$27)
H28 =SUMME($H$23:$H$27)
I28 =SUMME($I$23:$I$27)
G29 =WENN(ISTFEHLER(VERGLEICH(A29;$W$64:$W$81;0));WENN(A29="";"";INDIREKT("E"&WOCHENTAG(B29)+41));"")
G30 =WENN(ISTFEHLER(VERGLEICH(A30;$W$64:$W$81;0));WENN(A30="";"";INDIREKT("E"&WOCHENTAG(B30)+41));"")
G31 =WENN(ISTFEHLER(VERGLEICH(A31;$W$64:$W$81;0));WENN(A31="";"";INDIREKT("E"&WOCHENTAG(B31)+41));"")
G32 =WENN(ISTFEHLER(VERGLEICH(A32;$W$64:$W$81;0));WENN(A32="";"";INDIREKT("E"&WOCHENTAG(B32)+41));"")
A33 =SUMME(A29:A32)
G33 =SUMME($G$29:$G$32)
H33 =SUMME($H$29:$H$32)
I33 =SUMME($I$29:$I$32)
G34 =WENN(ISTFEHLER(VERGLEICH(A34;$W$64:$W$81;0));WENN(A34="";"";INDIREKT("E"&WOCHENTAG(B34)+41));"")
H34 =SUMMEWENN(A6:A35;"";G6:G35)
G35 =WENN(ISTFEHLER(VERGLEICH(A35;$W$64:$W$81;0));WENN(A35="";"";INDIREKT("E"&WOCHENTAG(B35)+41));"")

Zahlenformate
Zelle Format Wert
A26 TT.MM.JJJJ40171
B26 TTT40171
A27 TT.MM.JJJJ40172
B27 TTT40172
G28 0,007,5
A29 TT.MM.JJJJ40175
B29 TTT40175
G29 0,001,5
A30 TT.MM.JJJJ40176
B30 TTT40176
G30 0,002,5
A31 TT.MM.JJJJ40177
B31 TTT40177
G31 0,003,5
A32 TT.MM.JJJJ40178
B32 TTT40178
A33 TT.MM.JJJJ160706
G33 0,007,5
I34 TT.TTTHier Summe
Zellen mit Format Standard werden nicht dargestellt

Tabellendarstellung in Foren


gruss hary


  

Betrifft: AW: An Hary & Matthias von: Heinz H
Geschrieben am: 30.12.2009 17:32:47

Hallo Hary

Ja es funktioniert zu 100%

Auch wenn ich die Formel nicht kapiere !!

Recht herzlichen DANK !!!

Gruß
Heinz


  

Betrifft: AW: klaerung von: hary
Geschrieben am: 30.12.2009 17:36:18

Hallo Heinz
Du sumierst ja in Zellen(SpalteG). Analog dazu steht in SpalteA nichts drin.
Die Formel summiert nur Zellen in G wo in A nichts drin steht.
gruss hary


  

Betrifft: AW: klaerung von: Heinz H
Geschrieben am: 30.12.2009 17:42:28

Hallo Hary

Danke - Jetzt habe ich es kapiert !!

So einfach kann es oft sein - WENN gewusst WIE !!



Danke & Gruß
Heinz


  

Betrifft: nur nochmal ich ... von: Matthias L
Geschrieben am: 30.12.2009 18:31:16

Hallo Heinz

Du hättest natürlich schreiben können das es schon eine Vorgeschichte gibt.
hary wußte sofort Bescheid!

Ich hingegen habe mir Gedanken gemacht um Dein Problem zu lösen ohne die Vorgeschichte zu kennen.
Das war natürlich sehr ärgerlich. Du siehst, das ich weiterhin versucht habe eine andere Lösung zu finden.
Hier diese weitere Variante, die es möglich macht nur die SummenFormeln zu erkennen.
mit dem Excel4Makro =Zelle.Zuodnen() lässt sich die Formel als Text in der Nachbarzelle darstellen.

https://www.herber.de/bbs/user/66895.xls

Per VBA wird nun wieder das "x" gesetzt und mit "Summewenn() verarbeitet.



Warum poste ich das trotzdem ?
Damit andere iinteressierte Excelfreunde, die diese Möglichkeit noch nicht kennen auch etwas dazulernen können.

Gruß Matthias


  

Betrifft: AW: nur nochmal ich ... von: Heinz H
Geschrieben am: 30.12.2009 18:50:24

Hallo Matthias

Sorry das tut mir echt leid. Ich möchte mich höflichst bei dir Entschuldigen.

Da ich die Formel "SummenFormeln" nicht kannte,konnte ich auch keine Verbindung zu einem älteren Thread herstellen.

Es war absolut keine Absicht dich in irgendeiner Form zu kränken.

Ich hoffe du nimmst meine Entschuldigung an !!

Nochmals Danke, für deine immer gern gelesenen Ratschläge & Lösungen in diesen Forum.

Gruß
Heinz


  

Betrifft: ist schon ok ... kwT von: Matthias L
Geschrieben am: 30.12.2009 18:54:22




  

Betrifft: Danke Matthias, wird verwendet :-) owT von: robert
Geschrieben am: 30.12.2009 18:54:35




  

Betrifft: Hi Robert, dann wars ja nicht umsonst :o) owT von: Matthias L
Geschrieben am: 30.12.2009 19:08:26




  

Betrifft: AW: Beispiel Mappe von: hary
Geschrieben am: 30.12.2009 17:33:08

hallo Heinz
hier mal in der Mappe.
https://www.herber.de/bbs/user/66892.xls
gruss hary