Microsoft Excel

Herbers Excel/VBA-Archiv

Formel oder VBA Erhöhe Zahl um eines -wenn


Betrifft: Formel oder VBA Erhöhe Zahl um eines -wenn von: Silke D
Geschrieben am: 28.06.2017 21:25:03


Hallo, lieber Excel Kenner...

ist es möglich folgendes mit einer Formel zu realisieren- ohne VBA?

In Spalte A befindet sich eine Kennung 01.0029.17

Wird nun in B daneben ein Text eingetragen dann soll sich in A eine ´Zeile tiefer die Kennung wie folgt um eins erhöhen. 01.0030.17

Wenn nun wieder in B daneben ein Text eingetragen wird, dann soll sich wieder eine Zeile tiefer in A der Kennungswert um eine erhöhen. so etwa 01.0031.17

www.herber.de/bbs/user/114551.xlsx

Ist das mit einer Formel lösbar?

LG Silke D

  

Betrifft: AW: Formel oder VBA Erhöhe Zahl um eines -wenn von: Sepp
Geschrieben am: 28.06.2017 23:18:06

Hallo Silke,

so?

Tabelle2

 AB
201.0027.17Test
301.0028.17Test2
401.0029.17 
5  
6  
7  
8  

Formeln der Tabelle
ZelleFormel
A3=WENN(B2="";"";LINKS(A2;3)&TEXT(TEIL(A2;4;4)*1+1;"0000")&RECHTS(A2;3))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8



Gruß Sepp



  

Betrifft: AW: Formel funktioniert- Erhöhe Zahl um eines von: Silke D.
Geschrieben am: 30.06.2017 19:08:05

Hallo @ Sepp,
konnte mich erst jetzt melden.

Danke für die Lösung- funktioniert einwandfrei. Hätte ich nicht gedacht- ist ja immerhin in Spalte A eine spezielle Formatierung.

MfG Silke D
aus Sachsen


Beiträge aus den Excel-Beispielen zum Thema "Formel oder VBA Erhöhe Zahl um eines -wenn"