Microsoft Excel

Herbers Excel/VBA-Archiv

Formel Wenn - Dann + Bedingte Formatierung | Herbers Excel-Forum


Betrifft: Formel Wenn - Dann + Bedingte Formatierung von: Alex
Geschrieben am: 12.11.2009 18:06:58

Hallo Zusammen.!!

eigentlich möchte ich "nur" eine "bedingte Formatierung" aus bestimmten Buchstabenkombination in Textfeldern erstellen. Da ich aber nicht weiß, wie man in der Formel nach "Buchstabenteilen" sucht, wollte das in einem "Hilfsfeld" erledigen. Klappt aber auch nicht..!! :-(
Irgendwas funktioniert mit der Wenn-Berechnung nicht, aber ich finde es nicht heraus.

Zum besseren Verständnis habe ich eine Tabelle hochgeladen.
Ich hoffe, ihr könnt mir helfen oder habt sogar einen eleganteren Weg für die Formatierung..

Danke schon im Voraus..!!

https://www.herber.de/bbs/user/65829.zip

  

Betrifft: AW: Formel Wenn - Dann + Bedingte Formatierung von: Beate Schmitz
Geschrieben am: 12.11.2009 18:23:41

Hallo Alex,

 B
1Informationsfeld
2EM9100
3FM 19vk
4Alle_BFCH

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
B21. / Formel ist =LINKS(B2;2)="EM"Abc
B22. / Formel ist =LINKS(B2;2)="FM"Abc


Die Formel für die bedingte Formatierung ist kopierbar.

Guckst du:
Bedingte Formatierung (1) - Grundlagen
Bedingte Formatierung (2) - Beispiele allgemein
Bedingte Formatierung (3) - Weitere Anwendungsbeispiele
!Langsames Excel (2) - Bedingte Formatierung


Gruß,
Beate


  

Betrifft: Lösung per VERGLEICH(N(ISTZAHL(SUCHEN(...))) von: NoNet
Geschrieben am: 12.11.2009 18:37:18

Hallo Alex,

gib testweise folgende Funktion in C2 Deiner Tabelle ein (hier nur beispielhaft mit den 3 Werten "EM", "FM", "ALLE") :

=VERGLEICH(1;N(ISTZAHL(SUCHEN({"EM"."FM"."Alle"};B2)));0)

Die Zahl gibt Dir an, an der wievielten Stelle der Matrix {"EM"."FM"."Alle"} der Wert aus B2 gefunden wurden (1="EM", 2="FM" etc.) oder "#NV !", wenn der Wert nicht gefunden wurde.
Diese Matrix kannst Du in der Funktion nach dme gleichen Prinzip erweitern !

Mit dieser Funktion kannst Du dann die "Bedingte Formatierung" füttern, indem Du sie dort eingibst :

=VERGLEICH(1;N(ISTZAHL(SUCHEN({"EM"."FM"."Alle"};B2)));0)=1 - Format : GRÜN

=VERGLEICH(1;N(ISTZAHL(SUCHEN({"EM"."FM"."Alle"};B2)));0)=2 - Format : ROT

etc.

Gruß, NoNet


Beiträge aus den Excel-Beispielen zum Thema "Formel Wenn - Dann + Bedingte Formatierung"