Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
308to312
308to312
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Excel-Fehler bei komplizierte Summewenn mit Text

Excel-Fehler bei komplizierte Summewenn mit Text
17.09.2003 08:11:14
Andreas Grill
Hallo!

Ich habe folgende Ausgangssituation:
Tabelle 1 mit mehreren Spalten:
A _______ X
B _______ Y
C _______ Z

darunter Tabelle 2:
Überschrift Überschrift Überschrift
A _______ X _______ 2
B _______ Y _______ 4
C _______ Z _______ 8
Überschrift Überschrift Überschrift
A _______ X _______ 5
B _______ Y _______ 9
C _______ Z _______ 1
....

wie man sieht, wiederholen sich die Zeilen von Tabelle 1 in Tabelle 2 mehrmals mit einer Überschrift.
In Tabelle 1 soll nun in der 3 Spalte die Summe der entsprechenden Zeilen stehen.
Bisher standen der Überschriftszeile in der 3. Spalte keine Werte, und folgende Formel hat funktioniert: SUMMENPRODUKT(($A$10:$A$100=$A$1)*($B$10:$B$100=$B$1)*$C$10:$C$100)

Nun stehen aber auch Textwert in der Tabelle, wodurch die obige Formel den Fehler #WERT! zurückliefert.
Die abgewandelte Formel
SUMMENPRODUKT(($A$10:$A$100=$A$1)*($B$10:$B$100=$B$1)*WENN(ISTZAHL($C$10:$C$100);$C$10:$C$100;0))
liefert aber folgendes Ergebnis:

A _______ X _________________ 0
B _______ Y _________________ 0
C _______ Z _________________ 0
Überschrift Überschrift Überschrift 0
A _______ X _______ 2 _______ #WERT!
B _______ Y _______ 4 _______ #WERT!
C _______ Z _______ 8 _______ #WERT!
Überschrift Überschrift Überschrift 0
A _______ X _______ 5 _______ #WERT!
B _______ Y _______ 9 _______ #WERT!
C _______ Z _______ 1 _______ #WERT!

In dem Eingabefenster für die Formel (wenn man auf das "="-Symbol vor der Formel drückt) erscheint allerdings das richtige Ergebnis!
Hat irgendjemand eine Idee, wie ich zum richtigen Ergebnis komme? Weglassen der Überschrift bzw. des Textes ist nur die allerletzte Alternative.

Danke

Andreas Grill

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Excel-Fehler bei komplizierte Summewenn mit Text
17.09.2003 08:32:13
Andreas Grill
Inzwischen haeb ich folgendes festgestellt:
Wenn man in der Funktion IstZahl den Parameter statt dem Bereich mit F9 die fixierten Werte nimmt, kommt das richtige Ergebnis heraus.

Nur kann ich die Werte in meinem Fall nicht fixieren, da sich diese Ändern! Weiss wer eine Lösung?

Danke
AW: Excel-Fehler bei komplizierte Summewenn mit Text
17.09.2003 09:13:07
Panicman
Hallo Andreas,

wenn du deine Formel statt nur mit ENTER mit STRG-SHIFT-ENTER bestätigst funzt Sie auch mit Text. Du mußt halt eine Array-Formel daraus machen. In der Anzeige werden dann vor und nach der Formel geschweifte Klammern gezeigt.

Alternativ geht auch folgende Array-Formel:
{=SUMME(WENN(A10:A100&B10:B100=A1&B1;C10:C100))}

Also geschweifte Klamern nicht mit eingeben sondern die Formel mit STRG-SHIFT-ENTER abschließen

Gruß
Holger
Anzeige
AW: Excel-Fehler bei komplizierte Summewenn mit Text
17.09.2003 09:28:41
Andreas Grill
Das funktioniert nicht!

Die angegebene Formel liefert die Summe über alle Zeilen nur in der Zeile der Tabelle 2, wo die Werte mit dem Wert aus Tabelle 1 übereinstimmt.

Ich will aber in Tabelle 1!!! die Summe jener Werte aus Tabelle 2, wo die Werte mit Tabelle 1 übereinstimmen.
AW: Excel-Fehler bei komplizierte Summewenn mit Text
17.09.2003 09:51:38
Panicman
Hallo Andreas,

dann so:
=SUMMENPRODUKT((Tabelle2!$A$10:$A$100=A1)*(Tabelle2!$B$10:$B$100=B1)*WENN(ISTZAHL(Tabelle2!$C$10:$C$100);Tabelle2!$C$10:$C$100;0))}

oder
{=SUMME(WENN(Tabelle2!A10:A17&Tabelle2!B10:B17=A1&B1;Tabelle2!C10:C17))}

Gruß
Holger
AW: Excel-Fehler bei komplizierte Summewenn mit Text
17.09.2003 10:18:17
Andreas Grill
ok, danke, hab's jetzt hinbekommen wie ich's brauche!

danke
Andreas Grill
Anzeige
Bitteschön, hab gern geholfen o.T.
17.09.2003 11:18:46
Panicman

355 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige