Microsoft Excel

Herbers Excel/VBA-Archiv

Summewenn mit 3 Kriterien | Herbers Excel-Forum


Betrifft: Summewenn mit 3 Kriterien von: Tobias Kühnle
Geschrieben am: 15.10.2008 17:42:51

Guten Tag,
ich finde die summewenn-funktion sehr gut, stoße jetzt leider an die Grenzen.
Ich habe folgendes Problem:
Das Datentabellenblatt sieht wie folgt aus:
Spalte 1 Spalte 2 Spalte 3 Spalte 4
* AAA 111 50,26
* AAA 222 150,26
AAA 111 70,51
* BBB 111 950,26
* AAA 111 66,26
* CCC 111 66,26

In dem Ergebnistabellenblatt soll immer eine Summe gebildet werden wenn ein * in Spalte 1 steht.
z.B.
Summen AAA:
111: 120,77 (=50,26+70,51)
222: ....
.....

Summen BBB:
........

Kann ich das mit Excel ohne VBA lösen?

Vielen Dank vorab!

  

Betrifft: AW: Summewenn mit 3 Kriterien von: Disco
Geschrieben am: 15.10.2008 17:55:11

Hallo Tobias,



die Summenproduktformel sollte hier helfen. Mal ein Beispiel:



=SUMMENPRODUKT((A1:A100="*")*(B1:B100="AAA")*(C1:C100=111)*(D1:D100))



Die Bereiche und Kriterien müssen dann natürlich noch angepasst werden...



Viele Grüße

Henning


Beiträge aus den Excel-Beispielen zum Thema "Summewenn mit 3 Kriterien"