Das Archiv des Excel-Forums

Summe wenn Datum in einem bestimmten Bereich

Bild

Betrifft: Summe wenn Datum in einem bestimmten Bereich
von: Bilgin

Geschrieben am: 28.09.2003 12:10:32

hallo,

wahrscheinlich ist es fuer viele von euch kein problem aber ich komme nicht weiter.

Ich habe zwei spalten. In der ersten Spalte sind Betraege und in der andere spalte ein Datum, wann jedes dieser betraege generiert wurde. Nun zu meinem Problem. Ich habe 12 Felder angelegt, wobei jedes dieser Felder die Ueberschrift eines Monats hat. Ich moechte nun, das zum Beispiel im Januar Feld die Gesamtsumme der Betraege erscheint, die Im Januar erzeugt wurden.

Ich bin fuer jede Hilfe dankbar,

Gruss aus Shanghai
Bilgin
Bild


Betrifft: AW: Summe wenn Datum in einem bestimmten Bereich
von: Jörg Gradert
Geschrieben am: 28.09.2003 12:22:36

Hallo Bilgin,
mit Beträgen in Spalte A und Datum in Spalte B

Januar
=SUMMENPRODUKT((MONAT(B1:B1000)=1)*A1:A1000)

Februar
=SUMMENPRODUKT((MONAT(B1:B1000)=2)*A1:A1000)

usw.

Jahre werden so noch nicht unterschieden.

Gruss Jörg


Bild


Betrifft: AW: Summe wenn Datum in einem bestimmten Bereich
von: andreas e
Geschrieben am: 28.09.2003 12:24:00

Hallo bilgin,
sieh dir mal nachstehende Tabelle mit Hilfsspalte an !
Achtung ! Die Formel ist eine Matrixformel ! Geschwefte klammern nicht eingeben sondern mit strg-umsch-enter abschliessen.
 
 ABCDEF
101.01.20031000 1Januar2000
220.01.20031000 2Februar2000
308.02.20031000 3März1000
427.02.20031000 4April2000
518.03.20031000 5Mai1000
606.04.20031000 6Juni2000
725.04.20031000 7Juli2000
814.05.20031000 8August1000
902.06.20031000 9September2000
1021.06.20031000 10Oktober1000
1110.07.20031000 11November2000
1229.07.20031000 12Dezember0
1317.08.20031000    
1405.09.20031000    
1524.09.20031000    
1613.10.20031000    
1701.11.20031000    
1820.11.20031000    
Formeln der Tabelle
F1 : {=SUMME(WENN(MONAT(A1:A100)=D1;B1:B100))}
F2 : {=SUMME(WENN(MONAT(A2:A101)=D2;B2:B101))}
F3 : {=SUMME(WENN(MONAT(A3:A102)=D3;B3:B102))}
F4 : {=SUMME(WENN(MONAT(A4:A103)=D4;B4:B103))}
F5 : {=SUMME(WENN(MONAT(A5:A104)=D5;B5:B104))}
F6 : {=SUMME(WENN(MONAT(A6:A105)=D6;B6:B105))}
F7 : {=SUMME(WENN(MONAT(A7:A106)=D7;B7:B106))}
F8 : {=SUMME(WENN(MONAT(A8:A107)=D8;B8:B107))}
F9 : {=SUMME(WENN(MONAT(A9:A108)=D9;B9:B108))}
F10 : {=SUMME(WENN(MONAT(A10:A109)=D10;B10:B109))}
F11 : {=SUMME(WENN(MONAT(A11:A110)=D11;B11:B110))}
F12 : {=SUMME(WENN(MONAT(A12:A111)=D12;B12:B111))}
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
Gruß Andreas E http://www.skripteundaufgaben.de viele kostenlose Downloads und Links zu EXCEL und mehr

Bild


Betrifft: AW: Summe wenn Datum in einem bestimmten Bereich
von: Bilgin
Geschrieben am: 28.09.2003 13:14:53

Hallo Andreas oder Joerg,

Ich habe das sheet auf den Server geladen, ich habe es basiered auf deine antwort nicht hinbekommen. Vielleicht kannst Du es direct in mein Excel sheet machen. Ich waere euch mehr als dankbar weil ich fast die Krise bekomme und an einem Sonntag in China arbeiten muss.

Vielen dank im voraus

hier der link zum excel sheet

https://www.herber.de/bbs/user/1191.xls


Bild


Betrifft: AW: Summe wenn Datum in einem bestimmten Bereich
von: Jörg Gradert
Geschrieben am: 28.09.2003 13:38:16

Hallo Bilgin,
in E117 steht eine Formel, die der Obergrenze Zeile 1000 im Wege ist.
Ich habe die Obergrenze jetzt auf 116 gesetzt.

https://www.herber.de/bbs/user/1192.xls

Gruss Jörg


Bild


Betrifft: AW: Summe wenn Datum in einem bestimmten Bereich
von: Bilgin
Geschrieben am: 30.09.2003 17:02:06

Hallo Joerg,

Ich moechte mich nochmals bedanken, es hat nach Deiner Methode geklappt. Wenn Du mal je in Shanghai landen solltest, dann lad ich Dich zu einem Bier ein. Ich habe echt Ewigkeiten an dem Scheiss rumgemacht, wenn es einem nich einfaellt, dann faellt es einem einfach nicht ein.

Grusss
bilgin


Bild


Betrifft: Danke für die Einladung
von: Jörg Gradert
Geschrieben am: 30.09.2003 21:40:34

Hallo Bilgin,
schön, dass ich helfen konnte.

Gruss Jörg


 Bild

Excel-Beispiele zum Thema " Summe wenn Datum in einem bestimmten Bereich"

Befindet sich die aktive Zelle in einem bestimmten Bereich? download Werte eins bestimmten Monats summieren download
Werte 1 und 0 in einem bestimmten Verhältnis zufällig anordnen download Alle Links zu einer bestimmten Arbeitsmappe löschen download
Anzahl eines bestimmten Wochentages im Monat download Alle Dateien ab einem bestimmten Datum listen download
Daten eines bestimmten Jahres filtern download Zeilen löschen, wenn in bestimmten Spalten keine Werte stehen download
xlSaveAs-Dialog in einem bestimmten Verzeichnis aufrufen download Wert einer bestimmten Zelle merken download
Werte aus UserForm-TextBox in bestimmten Formate übertragen download Anzahl von Zellen mit einer bestimmten Hintergrundfarbe ermitteln download
Zeichenfolgen ändern, wenn ein sie einen bestimmten Text enthalten download Werte eines bestimmten Wochentages und eines Zeitbereiches addieren download
Bei Aktivierung einer bestimmten Tabelle in Vollbildmodus schalten download Anzahl eines Namens in einer bestimmten Schriftfarbe ermitteln download
Anzahl der Einträge zu einer bestimmten Kalenderwoche download Datenmaske mit einem bestimmten Datensatz aufrufen download
Aus Liste Anzahl der Januartage eines bestimmten Jahres listen download Letzte Zeile mit einem bestimmten Anfangsbuchstaben markieren download
Leerzeichen aus einem Bereich löschen download Mehrbereichsauswahl auf eine Seite drucken. download
Spalten einer Mehrbereichsauswahl ausblenden. download Bereich mit Maximalwert markieren download
Benannten Bereich erweitern download Bereich in RefEdit-Element eingeben und auslesen download
Benutzerdefinierte SVERWEIS-Funktion über mehrere Bereiche download Letzter Wert aus einem Bereich download
Bereiche bei Mehrfachauswahl prüfen download Auswahl eines Zellbereiches verhindern download
Bereiche in Abhängigkeit eines Zellinhaltes drucken download Den selben Bereichsnamen in mehreren Tabellenblättern download
Leere Zeilen und Spalten in ausgewähltem Bereich löschen download URLs eines ausgewählten Bereiches in HyperLinks umwandeln download
Werte aus Zellbereich in eine Matrix übernehmen und auslesen download Zellauswahl auf den ausgewählten Bereich beschränken download
Berechnung des ausgewählten Bereiches in der Statusleiste download Bereiche auf Übereinstimmung vergleichen download
Scrollbereich begrenzen download Tabellenblattbereich als Email versenden download
Serie von Bereichsnamenteilen einer Arbeitsmappe ändern download Worte in einem vorgegebenen Bereich zählen download
Bereichsnamen ermitteln und als Kommentare anzeigen download Bereichsnamen in UserForm-ListBox auflisten und editieren download
Einen vorgegebenen Tabellenblattbereich in neue Arbeitsmappe download Werte aus einem nicht zusammenhängendem Bereich auslesen download
Druckbereich variabel gestalten download Tabellenblattbereich sortiert als Zellkontextmenü download
Überschriften aus Spalte C in Spalte D in den relevanten Bereich download Druckbereich bis zum ersten Nullwert festlegen download
Markierten Bereich mit jeweiligem Mwst-Satz multiplizieren download Cursor in bestimmtem Zellbereich in Eieruhr verwandeln download
Maximalwert aus einem Bereich ermitteln und in Spalte A eintragen download Formelbereich in Einzelelemente aufschlüsseln download
Datenreihenbeschriftungs-Quellbereich ausserhalb des Datenbereiches download Diagramm-Datenbereich über Schaltfläche festlegen download
Abfrage zum Kopierbereich von Startzelle, Zeilen- und Spaltenanzahl download Einen von einer Schlüsselziffer abhängigen Bereich kopieren download
Namen eines ausgewählten Bereiches auslesen download Den in einer Zelle genannten Bereich eines Blattes drucken download
Zugriff auf Zellen unter Verwendung eines Bereichsnamens download Bereich aus anderer Tabelle für 2 Sekunden anzeigen download
Nur die sichtbaren Zellen eines AutoFilter-Bereiches einlesen download Aktuellen Bereich in den Spalten A:F als Druckbereich download
Über UserForm-RefEdit-Steuerelement Bereich auswählen download Über InputBox festzulegenden Bereich kopieren download
Anzahl der Übereinstimmungen in zwei Bereichen ermitteln download