Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
908to912
908to912
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Summe wenn Datum

Summe wenn Datum
29.09.2007 22:58:00
Jens
Hallo, ich habe 2 Probleme, ich hoffe Ihr könnt mir helfen.
In Spalte I steht das Datum.
Nun sollen alle Beträge in Spalte J3:J145 summiert werden, wenn das Datum im Sept. 2007 liegt.
Ich habe es mit
=SUMME(WENN(UND(MONAT($I$3:$I$145)=9;JAHR(I3:I145)=2007);$J$3:$J$145))
probiert, aber es klappt nicht. Habt Ihr eine Idee?
Das Zweite Problem bezieht sich auf die gleiche Datenbasis.
Es handelt sich um eine Tabelle mit Tankbelegen und dem Kilometerstand zum Zeitpunkt des Tankens.
Ich möchte mit einer Formel berechnen, wie viele Kilometer im Monat September gefahren wurden.
In Spalte K befindet sich der Kilometerstand zur jeweiligen Tankrechnung.
Kann mir hier jemand helfen?
Das war mein bisheriger Ansatz
=SUMME(WENN(MONAT($I$3:$I$145)=9;Max($K$3:$K$145)-Min(K3:K145))

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Summe wenn Datum
29.09.2007 23:04:53
Josef
Hallo Jens,
nutze SUMMENPRODUKT().
Tabelle1

 FGHIJKL
3   01.09.2007685  
4   04.09.2007624  
5   06.09.2007619  
6   08.09.2007666  
7   12.09.2007570  
8   16.09.2007718  
9   20.09.2007524  
10   22.09.2007649  
11   27.09.2007552  
12   29.09.2007610  
13   03.10.2007556  
14   04.10.2007653  
15   07.10.2007696  
16   10.10.2007586  
17   14.10.2007695  
18       
19       
20       
21       
22 Jahr:2007    
23 Monat:9    
24 Summe:6217    
25       
26       

Formeln der Tabelle
ZelleFormel
H24=SUMMENPRODUKT((MONAT($I$3:$I$17)=H23)*(JAHR($I$3:$I$17)=H22)*$J$3:$J$17)
Excel Tabellen im Web darstellen  Excel Jeanie HTML
Gruß Sepp

Anzeige
AW: Summe wenn Datum
29.09.2007 23:17:00
Jens
Hallo,
ich habe vergessen hinzuzufügen, dass die Tabelle ständig erweitert wird.
Ich habe die Tabelle angehängt.
Ich suche die Formel für D29 udn für C29
https://www.herber.de/bbs/user/46441.zip
Gruß Jens

AW: Summe wenn Datum
29.09.2007 23:05:33
{Boris}
Hi Jens,
=SUMME(WENN(UND(MONAT($I$3:$I$145)=9;JAHR(I3:I145)=2007);$J$3:$J$145))
Die Funktion UND gibt nur einen einzigen Wert (WAHR ODER FALSCH) und kein Array zurück.
Aus der Hand:
=SUMMENPRODUKT((MONAT($I$3:$I$145)=9)*(JAHR(I3:I145)=2007);$J$3:$J$145))
Zur zweiten Formel ist mir Deine Datenbasis nicht ganz klar.
Grüße Boris

Anzeige
AW: Summe wenn Datum
29.09.2007 23:06:00
Uduuh
Hallo,
zu 1
=summenprodukt((MONAT($I$3:$I$145)=9)*(;JAHR(I3:I145)=2007)*($J$3:$J$145))
Gruß aus’m Pott
Udo

zur zweiten Frage
29.09.2007 23:12:00
Josef
Hallo Jens,
Tabelle1

 FGHIJK
2   DatumKM-Stand 
3   01.09.200712108 
4   04.09.200712232 
5   06.09.200712309 
6   08.09.200712344 
7   12.09.200712423 
8   16.09.200712509 
9   20.09.200712653 
10   22.09.200712917 
11   27.09.200713074 
12   29.09.200713201 
13   03.10.200713269 
14   04.10.200713278 
15   07.10.200713325 
16   10.10.200713362 
17   14.10.200713406 
18      
19      
20      
21      
22 Jahr:2007   
23 Monat:9   
24 Summe:1093   
25      

Formeln der Tabelle
ZelleFormel
H24{=MAX(WENN((MONAT($I$3:$I$17)=H23)*(JAHR($I$3:$I$17)=H22); $J$3:$J$17)-MIN(WENN((MONAT($I$3:$I$17)=H23)*(JAHR($I$3:$I$17)=H22); $J$3:$J$17)))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen
Excel Tabellen im Web darstellen  Excel Jeanie HTML
Gruß Sepp

Anzeige

320 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige