Microsoft Excel

Herbers Excel/VBA-Archiv

Summewenn mit Formel als Bedingung

Betrifft: Summewenn mit Formel als Bedingung von: Frank Berends
Geschrieben am: 21.08.2014 12:36:23

Hallo zusammen,

ich habe folgende Tabelle
A B
1 Januar 67
2 Losnr.
3 1 1097991
4 1 1097992
5 1 1097993
6 Februar
7 Losnr.
8 2 1539180
9 2 1539181
10 2 1539182

Die Anzahl der Zeilen ist je Monat natürlich immer unterschiedlich. Ich möchte nun eine Gesamtanzahl der im Jahr verkaufen Lose haben. Leider stehen ja in der Tabelle je Monat immer auch die im Monat verkaufen Lose als Summe, sodass ich nicht einfach die Spalte B gesamt betrachen kann.

Daher dachte ich an sowas wie Summewenn(A:A;oder("Januar";"Februar"...);B:B). Damit möchte ich nur die Zahlen in B addieren, in denen in der gleichen Zeile der Monatsname (als Text) steht. Klappt natürlich nicht, aber wieso?

Gruß
Frank

  

Betrifft: ...Weil ODER einen Wahrheitswert liefert, ... von: Luc:-?
Geschrieben am: 21.08.2014 12:53:28

…Frank,
mit dem du wohl kaum vgln willst…! ;-]
Bilde die MonatsSummen mit TEILERGEBNIS (wie es ja auch AutoSumme macht) und die JahresSumme dann ebenfalls so (über die ganze Spalte B)!
Gruß, Luc :-?

Besser informiert mit …


  

Betrifft: AW: ...Weil ODER einen Wahrheitswert liefert, ... von: Frank Berends
Geschrieben am: 21.08.2014 12:57:04

Hallo Luc,

hört sich gut an. Ich hab mit TEILERGEBNIS noch nicht gearbeitet. Wie mache ich das am geschicktesten?

Gruß
Frank


  

Betrifft: Bilde mal eine AutoSumme, ... von: Luc:-?
Geschrieben am: 21.08.2014 13:20:41

…Frank,
dann weist du wie das aussieht. ;-)
Luc :-?


  

Betrifft: Stelle gerade fest, dass ... von: Luc:-?
Geschrieben am: 21.08.2014 13:43:24

1. bei deiner xlVersion nicht TEILERGEBNIS (ab xl10), sondern SUMME von AutoSumme verwendet wird,
2. das mit der Fkt nicht wie erwartet fktt!
Also dann die Methode TEILERGEBNISSE verwenden (in der xlHilfe nachlesen), dann dürfte es keine Probleme geben.
Luc :-?


  

Betrifft: 2. ist natürlich Quatsch gewesen, ... von: Luc:-?
Geschrieben am: 21.08.2014 15:53:07

…fktt natürlich auch mit der Fkt, Frank,
kann wohl schlecht im Kopf rechnen… ;-[
(Und dann noch weist statt weißt!)
Geht zB so:
B6:=TEILERGEBNIS(9;B3:B5) → Summe für Monat Januar
B13:=TEILERGEBNIS(9;B9:B12) → Summe für Monat Februar
Bn:=TEILERGEBNIS(9;Bm:Bn-1) → Summe für Monat Dezember
Bn+1:=TEILERGEBNIS(9;B3:Bn) → JahresSumme
Luc :-?


  

Betrifft: So, so, wenn Rudis Lösung genau ... von: Luc:-?
Geschrieben am: 21.08.2014 16:13:47

…das ist, was du suchst, Frank,
bin ich wohl von falschen Voraussetzungen ausgegangen. Werde mir abgewöhnen, auf solche mangelhaften Darstellungen wie zB deine hier künftig einzugehen. Es gibt genug Möglichkeiten, sein Problem eindeutig darzustellen! :-[
Luc :-?


  

Betrifft: AW: So, so, wenn Rudis Lösung genau ... von: Frank Berends
Geschrieben am: 21.08.2014 16:25:59

Hallo Luc,

wieso der scharfe Ton? Ist es in Foren nicht üblich, dass mehrere Teilnehmer antworten und sich der Anfragende dann für eine Lösung entscheidet (entscheiden muss)? Du hast in soweit aber recht, dass die Darstellung nicht unbedingt optimal ist.

Trotzdem besten Dank für Deinen Hinweis mit dem Teilergebnis, das kann mir u. U. an anderer Stelle weiterhelfen.

Gruß
Frank

Und an Daniel: ja, die Lösung mit =SUMMEWENN(A:A;"?*";B:B) läuft auch. Danke.


  

Betrifft: Wieso scharf? Ärgerlich wäre wohl ... von: Luc:-?
Geschrieben am: 23.08.2014 00:29:45

…richtiger gewesen, Frank,
denn dieser Satz von dir, Leider stehen ja in der Tabelle je Monat immer auch die im Monat verkauf(t)en Lose als Summe, sodass ich nicht einfach die Spalte B gesamt betrachen kann, hat mich aufs Glatteis geführt. Dass dann neben Januar noch eine 67 stand, habe ich folglich gar nicht mehr als Widerspruch empfunden.
Du wolltest die gesamte Spalte B „betrachten“ (⇒einbeziehen), was man mit TEILERGEBNIS tun kann, und „leider … auch“ heißt sicher nicht nur für mich, dass genau das stört. So vorpgmiert kann nur jemand, der über die Widersprüchlichkeit des Ganzen nachdenkt, die ihm dann natürlich auch auffallen muss, zu dem kommen, was du eigentlich willst, nämlich genau dem Gegenteil deiner Aussage!
Dieses Beschreibungsproblem ist weder neu noch selten, aber leider fällt man abundzu doch drauf rein. Deshalb meine abschließende, ärgerliche und überwiegend an mich selbst gerichtete Bemerkung, denn zum Erraten des tatsächlichen Problems eines Fragestellers ist mir meine Zeit eigentlich zu schade. So etwas machen Personal Trainer (und Problemlöser, am Arbeitsplatz), die man aber bezahlen muss… :->
Luc :-?


  

Betrifft: AW: Summewenn mit Formel als Bedingung von: Rudi Maintaire
Geschrieben am: 21.08.2014 12:57:52

Hallo,
sowas?

ABCDE
1Januar67   
2 Losnr. 8282
311097991   
411097992   
511097993   
6Februar15   
7 Losnr.   
821539180   
921539181   
1021539182   

ZelleFormel
D2{=SUMME(WENN(B2:B10="Losnr.";B1:B9;0))}
E2{=SUMME(WENN(ISTZAHL(FINDEN(LINKS(A1:A10;3);"JanFebMärApr"));B1:B10;0))}
Achtung, Matrixformel!
Die geschweiften Klammern{} nicht eingeben,
sondern die Zelle mit
Shift + Strg + Enter
verlassen statt Enter alleine.


Gruß
Rudi


  

Betrifft: Ich würde sagen, LosNr steht in A, Rudi! ;-) orT von: Luc:-?
Geschrieben am: 21.08.2014 13:22:57

Gruß, Luc :-?


  

Betrifft: AW: Summewenn mit Formel als Bedingung von: Frank Berends
Geschrieben am: 21.08.2014 14:25:54

Hallo Rudi,

das ist genau das, was ich gesucht habe. Und es läuft wunderbar.

Besten Dank

Frank


  

Betrifft: AW: Summewenn mit Formel als Bedingung von: Daniel
Geschrieben am: 21.08.2014 15:00:54

Hi
wenn die Tabelle so aufgebaut ist wie von Rudi gezeigt, müsste auch folgendes Funktionieren:

=SUMMEWENN(A:A;"?*";B:B)

Bildet die Summe, wenn in A ein Text steht, vor den Losnummern steht ja eine Zahl, damit werden diese nicht summiert:

oder
=SUMMEWENN(B:B;"<1000000")

das funktioniert, solange die Anzahl der verkauften Lose kleiner ist, als der Zahlenwert der kleinsten Losnummer (du musst hier die kleinste Losnummer als Kriterium eintragen)

Gruß Daniel


  

Betrifft: AW: Summewenn mit Formel als Bedingung von: Frank Berends
Geschrieben am: 21.08.2014 16:46:16

Hallo Daniel,

danke, =SUMMEWENN(A:A;"?*";B:B) läuft auch.

Gruß
Frank


  

Betrifft: AW: Summewenn mit Formel als Bedingung von: rene
Geschrieben am: 22.08.2014 01:27:05

Dsb5 r


  

Betrifft: AW: Summewenn mit Formel als Bedingung von: Frank Berends
Geschrieben am: 22.08.2014 08:15:24

Hallo Rene,

was soll das heißen, verstehe ich nicht.

Gruß
Frank


  

Betrifft: AW: Summewenn mit Formel als Bedingung von: rene
Geschrieben am: 23.08.2014 01:36:35

nicht von Bedeutung


 

Beiträge aus den Excel-Beispielen zum Thema "Summewenn mit Formel als Bedingung"