Microsoft Excel

Herbers Excel/VBA-Archiv

Summe aus Werten, wenn mehrere Bedingungen vorgege | Herbers Excel-Forum


Betrifft: Summe aus Werten, wenn mehrere Bedingungen vorgege von: Joerschi
Geschrieben am: 25.01.2010 20:15:08

Hallo liebes Forum,

ich suche eine bestimmte Excel-Funktion, finde sie aber nicht :-(.

Und zwar sollen in einer groooßen Tabelle in Spalte A alle diejenigen Werte summiert werden, welche verschiedene Bedingungen aus anderen Spalten erfüllen.
Als Beispiel habe ich die Problematik an Zahlen in der anliegenden Datei skizziert.
https://www.herber.de/bbs/user/67479.xls

Wahrscheinlich ist es eine Mischung aus Summenprodukt/Verweis etc., aber ich bekomms irgendwie nicht zusammen.

Weiß jemand Rat?

Liebe Grüße
Jörschi

  

Betrifft: AW: Summe aus Werten, wenn mehrere Bedingungen vorgege von: Christian
Geschrieben am: 25.01.2010 20:27:07

Hallo Jörschi,

mal als Ansatz

Tabelle1

 ABCDEF
1PreisKriterium 1Kriterium 2Kriterium 3  
22515ax 44
31014ax  
4810bx  
5915ay  
64513az  
7      

Formeln der Tabelle
ZelleFormel
F2=SUMMENPRODUKT((B2:B6>=14)*(B2:B6<=16)*(C2:C6="a")*((D2:D6="x")+(D2:D6="y"))*A2:A6)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

MfG Christian


  

Betrifft: AW: Summe aus Werten, wenn mehrere Bedingungen vorgege von: Joerschi
Geschrieben am: 25.01.2010 20:48:58

Hi Christian,

vielen Dank für den Tip. Das sieht schon sehr gut aus.
Allerdings zeigt es mir noch eine Fehlermeldung "#NV" an, weil eines der Kriterien (Spalte B) Prozente sind. Irgendwie will er da noch nicht wie ich wohl will...Grrr

Herzliche Grüße
Jörschi


  

Betrifft: AW: Summe aus Werten, wenn mehrere Bedingungen vorgege von: Joerschi
Geschrieben am: 25.01.2010 20:51:48

Ok - Fehler gefunden! Muss man die Prozente noch rausrechnen lassen.

Vielen Dank noch einmal!


  

Betrifft: da muss man dann... von: Christian
Geschrieben am: 25.01.2010 20:56:29

Hallo Jörschi,

..nur noch wissen, was Du mit Prozente genau meinst!
Ansonsten mal mit 0,14 bzw. 0,16 versuchen!

MfG Christian


  

Betrifft: AW: da muss man dann... von: Joerschi
Geschrieben am: 25.01.2010 21:05:21

Das habe ich.
Genauso hat es auch funktioniert.
Wie gesagt - Danke für die Hilfe. Damit komme ich auf jeden Fall weiter.
Jörschi


Beiträge aus den Excel-Beispielen zum Thema "Summe aus Werten, wenn mehrere Bedingungen vorgege"