Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
1232to1236
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

summewenn über zwei spalten (kriterien)

summewenn über zwei spalten (kriterien)
beatles
Hallo Zusammen
Ich versuche mit der Formel =summewenn() etwas abzufragen.
Ich habe Artikel-Nr. die in verschiedenen Lagern sind. Also ein Artikel kann also in mehreren Lagern vorkommen und die Kombination Artikel/Lager kommt auch mehrmals vor.
Am Ende habe ich Artikel und Lager kopiert und die Duplikate entfernt, damit Artikel nur noch mit je einmal Lager auftaucht.
Irgendwie funktioniert leider die summewenn Formel nicht wenn ich als Kombination Artikel/Lager verwenden möchte. Mache ich etwas falsch oder funktioniert die Formel in diesem Zusammenhang nicht?
Hier mein Beispiel:
https://www.herber.de/bbs/user/77187.xls
AW: summewenn über zwei spalten (kriterien)
25.10.2011 18:11:15
Uwe
Hi,
das geht über SUMMENPRODUKT.
Formel in J2:
=SUMMENPRODUKT(($A$2:$A$8=G2)*($B$2:$B$8=H2)*($C$2:$C$8+$D$2:$D$8+$E$2:$E$8))
und runterkopieren.
Klappt es?
Gruß
Uwe
(:o)
AW: Datei mit Summenprodukt zurück
25.10.2011 18:19:17
Uwe
Hi,
=SUMMENPRODUKT(($A$2:$A$8=G2)*($B$2:$B$8=H2)*($C$2:$E$8))
ist natürlich besser.
Ich hatte das auch ausprobiert, aber irgendwie ein Vielfaches der Summe bekommen.
Keine Ahnung, welchen Fehler ich da 'reingebaut hatte?!
Gruß
Uwe
(:o)
Anzeige
..nur wer nichts tut, macht keine Fehler ;-) oT
25.10.2011 19:08:09
robert
AW: ..woher kennst Du meine Chef? (;o) o.T.
25.10.2011 19:48:54
Uwe
Gruß
Uwe
(:o)
..ich hatte 17 Jahre so einen ;-)) oT
26.10.2011 08:30:29
robert
AW: Datei mit Summenprodukt zurück
26.10.2011 08:00:05
beatles
hallo robert
vielen dank es funktioniert.
ich habe noch eine frage wenn nun in einer zelle anstelle eines wertes ein text steht wie z.b. "kein Bestand" dann funktioniert die formel leider nicht. (#WERT)
habe auch versucht deine formel noch mit =wennfehler() zu verpacken aber funktioniert auch nicht.
gibt es da noch eine möglichkeit, dass bei text die formel trotzdem funktioniert..?
..warum denn Kein Bestand ..?
26.10.2011 09:04:18
robert
Hi,
warum muss da "Kein Bestand" stehen?
Null ( 0) ist doch kein Bestand !
Gruß
robert
machts doch mit dem ZellFormat ...
26.10.2011 09:06:58
Matthias
Hallo zusammen
Tabelle1

 ABCDEFGHI
1Art.-Nr.LagerAnzahl 1Anzahl 2Anzahl 3 Artikel-Nr. LagerTotal Anzahl pro Artikel / Lager
21014846000600084522 10148460006000899
3101484600060002kein Bestand3 101484160016009
410148460006000kein Bestand45kein Bestand 101484160020001
51014841600160022kein Bestand 1014846000130029
610148416002000kein Bestandkein Bestand1    
71014846000130031214    
81014841600160014kein Bestand    

Formeln der Tabelle
ZelleFormel
I2=SUMMENPRODUKT(($A$2:$A$8=G2)*($B$2:$B$8=H2)*($C$2:$E$8))
I3=SUMMENPRODUKT(($A$2:$A$8=G3)*($B$2:$B$8=H3)*($C$2:$E$8))
I4=SUMMENPRODUKT(($A$2:$A$8=G4)*($B$2:$B$8=H4)*($C$2:$E$8))
I5=SUMMENPRODUKT(($A$2:$A$8=G5)*($B$2:$B$8=H5)*($C$2:$E$8))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Format: Standard;-Standard;"kein Bestand"
Bei der Eingabe von 0 (Null) wird kein Bestand angezeigt
Gruß Matthias
Anzeige
..gute Idee und so einfach... ;-) oT-Gruß
26.10.2011 09:16:19
robert
AW: machts doch mit dem ZellFormat ...
26.10.2011 09:20:28
beatles
ja es steht "kein Bestand" weil dass von einer wennformel kommt und zu besseren Übersicht...
aber habe jetzt anstelle von "kein Bestand" "0" genommen... Danke

319 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige