Live-Forum - Die aktuellen Beiträge
Datum
Titel
25.06.2024 22:07:02
25.06.2024 21:01:55
25.06.2024 19:21:44
Anzeige
Archiv - Navigation
292to296
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
292to296
292to296
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Summe aus den letzten 6 zeilen einer spalte

Summe aus den letzten 6 zeilen einer spalte
13.08.2003 10:57:30
Steffen
Ich will aus einer spalte, die laufend um zeilen ergänzt wird, immer aus den letzten 6 (unten der spalte zugfügten)werten den Durchschnitt bilden. Wie geht das??
Vielen Dank im voraus für die Hilfe

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Mittelwert: letzte 6 zeilen von Spalte A (Array)
13.08.2003 11:14:51
WF
Hi Steffen,

=SUMME(INDIREKT("A"&KGRÖSSTE((A1:A1000<>"")*ZEILE(1:1000);6)):INDIREKT("a"&MAX((A1:A1000<>"")*ZEILE(1:1000))))/6

ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter; - das erzeugt sie.

trapp, trapp, trapp, trapp, trapp, brrrrr
WF

http://www.excelformeln.de/
die ultimative Formelseite


AW: Mittelwert: letzte 6 zeilen... - alternativ:
13.08.2003 12:13:35
Boris
Hi Walter, hi Steffen,

{=SUMME(BEREICH.VERSCHIEBEN(INDEX(A:A;MAX((A1:A1000<>"")*ZEILE(1:1000)));;;-6;))/6}
oder
{=MITTELWERT(BEREICH.VERSCHIEBEN(INDEX(A:A;MAX((A1:A1000<>"")*ZEILE(1:1000)));;;-6;))}

Grüße Boris


Anzeige
oder mit bereich.verschieben()
13.08.2003 12:15:46
ingo
HAllo zusammen,
funktioniert auch mit folgender Matrixformel:

=SUMME(BEREICH.VERSCHIEBEN(A1;MAX(ZEILE(A1:A1000)*(A1:A1000<>""))-6;0;6;1))/6

oder kürzer

=SUMME(BEREICH.VERSCHIEBEN(A1;MAX(ZEILE(A1:A1000)*(A1:A1000<>""));0;-7;1))/6

Gruß Ingo


Und, was ist, wenn LEERZELLEN vorkommen ?!
13.08.2003 12:21:22
WF
.


summenprodukt()
13.08.2003 13:09:50
ingo
HAllo WF???,

wenn leerzeilen vorkopmmen können:

=SUMMENPRODUKT((ZEILE(A1:A1000)>=KGRÖSSTE((A1:A1000<>"")*ZEILE(A1:A1000);6))*A1:A1000)/6

(keine Matrixformel)

Gruß Ingo


kürzer = besser ..... aber
13.08.2003 13:45:04
WF
Hi Ingo,

.....SUMMENPRODUKT ist dennoch eine Matrixformel; - man muß sie nur nicht
mit Strg Shift Enter abschließen, denn ganze Spalten (A:A) werden auch
hier nicht akzeptiert.

Salut


Anzeige

324 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige