Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema Image
BildScreenshot zu Image Image-Seite mit Beispielarbeitsmappe aufrufen

spez. summewenn für mehrere Kri. und Bereiche | Herbers Excel-Forum


Betrifft: spez. summewenn für mehrere Kri. und Bereiche von: Lukas Baumgartner
Geschrieben am: 04.01.2010 09:21:07

Hallo zusammen

ich komme mit meinen Excelkenntnissen an meine Grenze und brauche eure Hilfe. Folgendes Problem:

ich habe 2 Arbeitsblätter: Tab1 und Tab2

Im Tab1 steht:
in der Spalte B Namen von Artikeln;
in der Spalte D div. Menge von Zahlen {1;2;3;4};
in der Spalte F die summierenden Zahlen

im Tab2 steht:
in A3 der Namen des Artikels von welchem man die Summe bestimmen möchte
in B3 die Anfangszahl für die Zahlen Menge
in C3 die Endzahlt für die Zahlen Menge

Meine bisherige Formel bringt mir die richtige Summe für die Zahlenmenge, doch ohne Berücksichtigung des Artikelnamens.

{summe(summewenn(tab1!d1:d100;zeile(indirekt(b3&":"&c3));Tab1!f1:f100}

hat jemand eine Idee, wie ich die Formel summewenn nochmals ausbauen kann, damit auch der Artikelname berücksichtiget wird?
Summenprodukt funktioniert bei diesem Problem nicht, da es sich um Mengen/Vektoren ({}) handelt.

Vielen Dank für eure Hilfe.
Gruss Lukas

  

Betrifft: AW: spez. summewenn für mehrere Kri. und Bereiche von: Klaus-Dieter
Geschrieben am: 04.01.2010 09:34:08

Hallo Lukas,

versuche es doch einfach mal mit der Standardfunktion Summenprodukt.



Viele Grüße Klaus-Dieter

Klaus-Dieter's Excel und VBA Seite
Online-Excel



  

Betrifft: AW: spez. summewenn für mehrere Kri. und Bereiche von: Lukas Baumgartner
Geschrieben am: 04.01.2010 09:51:18

Wie schon erwähnt funktioniert dies nicht und gibt die Fehlermeldung #NV

Das Problem habe ich schon gefunden:

durch die Suchmenge/-vektor {1;2;3;4} (kann sich beliebig ändern) schaut die Formel SUMMENPRODUKT nur die ersten 4 Zellen an von dem ganzen Bereich (1:100) (dies ist auf die Anzahl im Suchvektor zurückzuführen), bei diesen 4 Zellen gibt es entweder Wahr oder Falsch, doch bei allen anderen kommt nur #NV. Dadurch ergibt sich diese Endfehlermeldung #NV.

Gruss, Lukas


  

Betrifft: AW: spez. summewenn für mehrere Kri. und Bereiche von: Klaus-Dieter
Geschrieben am: 04.01.2010 10:03:04

Hallo Lukas,

bei Summenprodukt musst du die Veektoren duch Punkte trennen, nicht durch Semikolon. Das hatten wir in den Beispielen auch dargestellt.



Viele Grüße Klaus-Dieter

Klaus-Dieter's Excel und VBA Seite
Online-Excel



  

Betrifft: AW: spez. summewenn für mehrere Kri. und Bereiche von: Erich G.
Geschrieben am: 04.01.2010 10:10:27

Hi Lukas,
meinst du evtl. so etwas?

 ABCD
2ArtikelvonbisSumme
3ArtA12202

Formeln der Tabelle
ZelleFormel
D3=SUMMENPRODUKT((A3=Tab1!B1:B100)*(B3<=Tab1!D1:D100)*(Tab1!D1:D100<=C3)*Tab1!F1:F100)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: spez. summewenn für mehrere Kri. und Bereiche von: Lukas Baumgartner
Geschrieben am: 04.01.2010 11:33:49

Merci Erich für deine Idee, sie funktioniert nicht für 100% so, wie ich mir das würde wünschen.
ich hätte gerne, die summe für jede zahl in meinem suchvektor {}.

@ Klaus-Dieter: leider konnte ich deinen Link des Summenprodukt nicht öffnen...
meine Formel:
=SUMMENPRODUKT((A3=tab1!B1:B100)*(tab1!D1:D100={1.2.3.4})*tab1!F1:F100)
funkttioniert lieder nicht. der Vektor wird in 1.234 umgewandelt

Vielen Dankt für die richtige Korrektur.
Gruss, Lukas


  

Betrifft: AW: spez. summewenn für mehrere Kri. und Bereiche von: Klaus-Dieter
Geschrieben am: 04.01.2010 11:37:22

Hallo Lukas,

neuer Versuch: Summenprodukt



Viele Grüße Klaus-Dieter

Klaus-Dieter's Excel und VBA Seite
Online-Excel



  

Betrifft: AW: spez. summewenn für mehrere Kri. und Bereiche von: Lukas Baumgartner
Geschrieben am: 04.01.2010 11:53:07

Jetzt konnte ich es öffnen, doch auch wenn ich deine ausgeschriebene Formel in eine Zelle kopiere, kommt genau das gleiche Problem, dass ich oben geschildert habe.

könnte dies an meiner Excelversion liegen? (Excel 2003)

Gruss, Lukas


  

Betrifft: AW: spez. summewenn für mehrere Kri. und Bereiche von: Klaus-Dieter
Geschrieben am: 04.01.2010 13:57:17

Hallo Lukas,

nein, das ist auch mit Excel 2003 erstellt.



Viele Grüße Klaus-Dieter

Klaus-Dieter's Excel und VBA Seite
Online-Excel



  

Betrifft: Beispielmappe? von: Erich G.
Geschrieben am: 04.01.2010 12:07:57

Hi Lukas,
aus deinen Beschreibungen wird mir nicht klar, was du eigentlich möchtest.

Was bedeutet "die summe für jede zahl in meinem suchvektor {}" genau?

Was genau steht in Tab1, Spalte D?
Meint "div. Menge von Zahlen {1;2;3;4}" z. B. den Text "{1.2.3.4}" in Zelle D2?

Könntest du nicht eine aussagekräftige Beispielmappe hochladen, mit den beiden Blättern
und dem/den gewünschten Ergebnis(sen)?

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Beispielmappe? von: Lukas Baumgartner
Geschrieben am: 04.01.2010 13:11:46

hallo erich
unter dem folgenden link findest du die beispielsmappe.

https://www.herber.de/bbs/user/66970.xls

vielen dank für deine Rückmeldung
Gruss, Lukas


Beiträge aus den Excel-Beispielen zum Thema "spez. summewenn für mehrere Kri. und Bereiche"