Übereinstimmung in mehrerern Spalten suchen

Bild

Betrifft: Übereinstimmung in mehrerern Spalten suchen
von: Martin
Geschrieben am: 06.07.2015 11:08:11

Hallo zusammen,
ich bin (zumindest als Beitragsschreiber) neu hier im Forum, als Leser habe ich hier aber schon oft Hilfe gefunden!
Vielleicht kann mir ja bei meinem Problem jemand weiterhelfen.
Ich habe eine Tabelle mit vier Spalten (siehe Bild)
In der Eingabemaske möchte ich den gewünschten Ø und die mm (liegt zwischen mm min und mm max) angeben.
In der Ausgabe sollte der passende Wert aus Spalte A ausgegeben werden.
Ist dies so möglich?
Danke schonmal für eure Mühe und viele Grüße,
Martin
Userbild

Bild

Betrifft: AW: Übereinstimmung in mehrerern Spalten suchen
von: {Boris}
Geschrieben am: 06.07.2015 12:19:39
Hi Martin,
z.B. so:
{=INDEX(A3:A8;MIN(WENN((B3:B8=F4)*(C3:C8<=G4)*(D3:D8>=G4);ZEILE(1:6))))}
Aaaaber:
Was soll bei z.B. ¢ 0,4 und 10mm rauskommen? x oder y?
D.h., die Min/Max-Werte - wie in diesem Fall - müssen differieren - als z.B. 9,99999999999 und 10.
Gleiches gilt für ¢ 0,2.
VG, Boris

Bild

Betrifft: auch hier ist AGGREGAT() möglich und ...
von: der neopa C
Geschrieben am: 06.07.2015 15:50:21
Hallo Martin,
... und im Zusammenspiel mit WENNFEHLER() kannst Du auch Nicht- und oder Fehleingaben einfach abfangen und zwar mit folgender Formel:
=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE(A1:A9)/(B1:B9=F4)/(C1:C9<=G4)/(D1:D9>=G4);1))&"";"")
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Übereinstimmung in mehrerern Spalten suchen
von: Martin
Geschrieben am: 10.07.2015 08:17:12
Vielen Dank für eure Hilfe!
Beide Lösungen haben super funktioniert. Da ich auch Fehleingaben abfangen muss verwende ich jetzt die Lösung mit AGGREGAT().
Grüße,
Martin

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Übereinstimmung in mehrerern Spalten suchen"